x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lightmass - Severe black artifacts on Speedtrees

Hey everyone!

I've previously brought this issue into the Speedtree forum, but they were sadly unable to identify it, which is why I'm trying my luck here.

I've currently been stuck with an issue regarding a couple of modified Speedtrees that were based on some models they sold at their store. Whenever I do a lighting build with basic skylight I'm getting some artifacts on the lightmaps, mainly the trunk. In more lighter areas they look like what appear to be visible UV seams, with a harsh transition from bright to dark areas. In more shadowy areas the artifacts are extremely present, resulting in thick black areas going through the entire trunk.

alt text (Example scene)

alt text (Lighting only)

The light map density of these was entirely green in both the Speedtree Modeller and UE4, with the light map UVs efficiently laid out. So far I've tried to specifically increase the trunk's UV area, but even with a super high light map density and the light map resolution cranked to 1024 I'm still getting these issues. I've also tried increasing the lighting quality, as well as skylight bounces to some high numbers, but these artifacts remain.

These trees are modified versions of the Norway Spruce Species Pack from their store, and I first thought that this problem was related to the modifications I made. But to my surprise I had the same exact issue with the unmodified trees straight from the store.

So far I've tried checking Recompute Normals/Tangents, as well as cranking up the lightmass quality settings and increasing the skylight bounces, but without any luck. I had a suspicion that it might be related to the low poly nature of the assets, so I also tried increasing the segments on the trunk, but it didn't make a difference. Something I've noticed though, is that these artifacts mostly occur in darker areas. In a bright, open area the trees are coming out just fine for me.

alt text (Black areas on trunks of speed trees, notice how other tree assets look perfectly fine.)

alt text (Artifacts only seem to appear in darker areas, trees in open areas look fine.)

All of these speed trees have a lightmap resolution of 512, I made sure to increase the UV coverage of the trunk until it was completely red to illustrate that it's not a problem with the resolution itself. The Lightmass settings are turned up to 6 skylight bounces and an indirect lighting quality of 3.0, which is certainly higher than Unreal's default settings. In addition, here's a look at the tree itself.

alt text

Any help would be greatly appreciated, been stuck with this problem for about 2 weeks now. :(

Product Version: UE 4.19
Tags:
more ▼

asked Mar 08 '19 at 08:30 AM in Rendering

avatar image

Denny_S
1

avatar image King Mango Mar 08 '19 at 03:27 PM

Look like an indirect lighting issue. Distance Field AO might help. Somewhere in one of his lighting academy videos 51Daedalus gives a good overview. Might try starting here: https://www.youtube.com/watch?v=grN5Yd55UIM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question