x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Dynamic Nav Mesh rebuilds incorrectly

Hello. What i can see in the editor wiev: alt text

And this in simulation: alt text

Rebuild doesn't help. I have to create a new map every time.

Product Version: UE 4.20
Tags:
more ▼

asked Mar 10 '19 at 05:03 PM in Using UE4

avatar image

OWRING
6 1 2

avatar image SparkyTheTorch02 Mar 10 '19 at 11:06 PM

I would help, but I don’t think there’s enough information to answer your question. To me it just looks like there is a nav mesh that you say was built incorrectly, I can’t tell what’s wrong, and the 2 photos look correct as far as I can’t tell. Please tell me if I am missing something I would love to help!

avatar image OWRING Mar 11 '19 at 07:33 AM

Is there any way to refresh navmesh building date? (Build button didn't help) When i'm delete nav mesh volume and create new one, in the editor it's looks like all correct (green space on the floors). But characters didn't walk while simulation. When i use console command "show navigation" green space locating in the wrong place. It`s starts after moving nav mesh volume (first creating rooms with navmesh is ok. After mooving rooms with navmesh it's starts). Thanks for being willing to help me.

avatar image SparkyTheTorch02 Mar 16 '19 at 12:11 AM

Sorry for getting back late. It may be because you are in simulation mode or PIE. Try using a new editor window or a standalone game. If not, check out this link: https://docs.unrealengine.com/enus/Resources/ContentExamples/NavMesh/1_3

and poke around a little. Also, are the actors static meshes or something else, i believe it wont work if they are not static meshes.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question