x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

iOS Packaging code sign error

I've been having this issue that just started happening. I've packaged this project dozens of times with no issues. This just randomly started yesterday. Whenever I build for IOS it fails with this error:

ATHelper: Packaging (iOS): Code Signing Error: Automatic signing is unable to resolve an issue with the "StarDomain" target's entitlements. Switch to manual signing and resolve the issue by downloading a matching provisioning profile from the developer website. Alternatively, to continue using automatic signing, remove these entitlements from your entitlements file and their associated functionality from your code. UATHelper: Packaging (iOS): Code Signing Error: Provisioning profile "iOS Team Provisioning Profile: Hershberg.StarDomain0.1" doesn't match the entitlements file's value for the get-task-allow entitlement. UATHelper: Packaging (iOS): Code Signing Error: Code signing is required for product type 'Application' in SDK 'iOS 12.1'

Best I could find online is this stack overflow thread: https://stackoverflow.com/questions/55132628/provisioning-profile-doesnt-include-the-application-identifier-and-keychain-acc

Has anyone else been having this issue with unreal? None of the solutions there seem to help. I tried just about everything and can't seem to fix this.

Product Version: UE 4.21
Tags:
more ▼

asked Mar 16 '19 at 05:33 AM in Packaging & Deployment

avatar image

BigJohn83
11 1 2 2

avatar image BigJohn83 Mar 17 '19 at 05:00 AM

So I was able to narrow this down to having a C++ class inside my Blueprint project. I tried it out on a new project as well. If I make a new project and package for iOS using my regular provisions, it works just fine. If I add a C++ class and let the engine compile, and then try and build for iOS, it'll give a provisioning error.

Anyone ever run across this before?

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question