x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Crashing in 4.4 launching from Visual Studio

I just updated to 4.4 today. (Downloaded from GitHub and compiled myself.)

When launching from Visual Studio with the project name as the debugging command argument, I assert out every time I open a map in F3D311Dynamic::RHI::CreateUniformBuffer() on line 207 because Inresources[I] is null.

If I launch without the command argument, and then pick the project, the map opens. If I launch by double clicking the uproject, the map opens. If I run the editor in Debug mode with or without the command line, the map opens.

Product Version: Not Selected
Tags:
more ▼

asked Aug 24 '14 at 08:38 PM in Bug Reports

avatar image

BrynBennett
46 2 6 8

avatar image Tim C ♦♦ STAFF Aug 25 '14 at 05:54 PM

Hi BrynBennett,

Could you provide some more information about how you are reproducing this issue? I created a new 4.4 project and tried to reproduce this several different ways and did not see the issue you described (I did get some error messages with some of the methods that I tried, but I was expecting those to appear).

  • Where are you setting your command argument and what is the exact argument you are using?

  • How are you launching the project using Visual Studio?

avatar image BrynBennett Aug 25 '14 at 06:14 PM

I'm just putting the uproject name in my command line. That's the only argument I have. However, if I put -debug, I end up getting the same assert.

Additionally, if I do this from debug mode, the map also works fine.

avatar image Tim C ♦♦ STAFF Aug 25 '14 at 07:59 PM

Are you using the UnrealVS extension included with the Engine and that is where you are setting your command-line argument, or are you changing it in the properties for your project or the solution? Are you entering your exact project name, or do you use the macros available in Visual Studio?

When you launch the project, do you just press F5? What is your Solution Configuration set to?

Is this happening in a project that you upgraded from a previous version of the Engine? If so, are you able to reproduce it in a new project created in 4.4?

avatar image BrynBennett Aug 25 '14 at 08:48 PM

I'm setting it in the debug section of the properties for my game's project in VS.

Yes, F5. The configuration is set to Development Editor. In Debug Editor, it doesn't happen.

It is from a project that I upgraded from 4.1. I haven't tried a new one from 4.4. I can give that a shot.

avatar image Tim C ♦♦ STAFF Aug 26 '14 at 06:33 PM

I created a project named "TestLaunch1" using version 4.1.0, then upgraded it through each Engine version until I got to 4.4.0. I then pulled up the project properties and went to the Debugging section and changed the Command Argument field to several variations of the project name.

Command Arguments

These are the results that I saw when I pressed F5 (TestLaunch1 was set as the startup project in VS):

Using either TestLaunch1 or "TestLaunch1" in the Command Argument field: "Failed to open descriptor file" error message.

Using -TestLaunch1, "-TestLaunch1", -debug or "-debug" in the Command Argument field: The Project Browser opens instead of the TestLaunch1 project, opening the TestLaunch1 project stops Visual Studio debugging and opens a new instance of the Editor. I can open different .umap files without any problems.

Using the default value (seen in the image above): The TestLaunch1 project opens in the Editor and VS remains in debug mode. I can open different .umap files without any problems.

Adding -debug or "-debug" after the default value: The TestLaunch1 project opens in the Editor and VS remains in debug mode. I can open different .umap files without any problems.

Where do my steps differ from what you are doing?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi BrynBennett,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Sep 08 '14 at 10:57 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question