x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged games does not start on integrated Intel Graphics Cards

Packaged Game Crashes to desktop on Intel Integrated Graphics Card

Hello,

I've been having an issue where my for my packaged game (blueprint project) is crashing to desktop without any errors/crash logs.


Issue Outline

  • Issue only seems to happen to integrated Intel graphics cards

  • its been experienced by a handful of people running the latest build of my game and they are all on integrated Intel GPU cards.

  • This issue seems to have appeared after I migrated my project to unreal engine 4.21.2

  • This crash does not occur for my last build which uses the previous Unreal Engine Version 4.20.3

  • This crash does not create any crash logs

    Step taken to resolve the issue

  • I have no packaging errors in my game but I've tried resolved as much of the packaging warning (yellow) as I can.

  • Strangely, I've packaged a template game (flying game) in unreal (4.21.2) and that crashed in the same manner.

  • The same template game (flying game) created using 4.20.3 works so it seems to be limited to the latest version of UE

  • I thought this issue could be related to visual studio so I've tried to:
    • reinstalling visual studio 2017

    • compile using Visual Studio 2015 and has the same issue.

  • Reinstalled unreal engine.

  • Delete intermediate/binary/save folder in project folder.


Test Laptop Specs: CPU: Intel i5 - 3337U Memory: Memory : 4GB Video Card: Intel HD Graphics 4000

I would greatly appreciate any assistance to help me resolve this issue.

Product Version: UE 4.21
Tags:
more ▼

asked Mar 18 '19 at 12:52 PM in Packaging & Deployment

avatar image

krishcrush_
112 3 8 12

avatar image sujansh Mar 25 '19 at 02:55 PM

Has been happening to me too on packaged builds after an upgrade to 4.21.2 on Intel-only integrated graphics

avatar image krishcrush_ Mar 28 '19 at 08:20 AM

Glad to hear that I'm not the only one who is experiencing this.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question