x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Poor shadow quality with correct size lighmaps

Hi everyone!

I'm quite new to the engine, so I'm probably missing something easy. Hopefully you'll be able to guide me to a solution.

Problem: I'm trying to light a low-poly cave with simple torches. However, there's no way I can get it right. The static mesh that creates the cave is split in several parts, each with a 1024 px resolution lightmap. This resolution should work fine, as I have similar sized meshes on the outside with 512 px lightmaps that work just fine. Moreover, when I use the lightmap density viewmode, everything has a good light blue/green color, so I suppose that's ok. The point lights placed on the torches are set to stationary and you can find their settings in the screenshots below. As you can see in the image provided, the shadows look good when close to the light source, but then rapidly become horrible. Maybe it's some kind of problem with indirect lighting? I have no clue.

Any kind of insight is extremely appreciated. Thank you in advance to anyone willing to help!alt text

alt text

Product Version: UE 4.21
Tags:
more ▼

asked Mar 18 '19 at 04:13 PM in Using UE4

avatar image

Lord Broblord
3 1 1

avatar image Ego Studio Mar 18 '19 at 06:21 PM

What kind of result do you want to reach ? If you cloud clarify "...but then rapidly become horrible".

avatar image Lord Broblord Mar 18 '19 at 06:41 PM

The shadows become blotchy and really ugly, as showed in the image below the red X. I think Unreal can generate far better shadows in low light environments, am I wrong?

avatar image Ego Studio Mar 18 '19 at 07:39 PM

You may try to set up Ambient Occlusion and put some lights with low intensity then play with cold colors like blue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Solved!

If you are experiencing this problem, try tweaking the Lightmass Settings in your World Settings. After some trial and error, I found that increasing the Num Indirect Lighting and the Indirect Lighting Quality and Smoothness helps a lot, but it will increase a lot your build times, so be careful!

more ▼

answered Mar 28 '19 at 10:39 AM

avatar image

Lord Broblord
3 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question