x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Fatal Error on launching, INT_DIVIDED_By_ZERO, and no way to track it down...

Hey !

Okay, so, I've been working on a project fro a long moment, and we've been able to build it without problems for months ! But today, when launching our Monday Build, I get a fatal error, without explanation, and by looking at the log, this is what I get : https://pastebin.com/jtpwDW5G

I was wondering if anyone would have any idea on how to find this division by 0. I hope I d'ont have to dig through all the bp (around 50) to find it. the advantage is that we are using git, so in cas of extrem necessity, I can still get a previous version easily...

hope anyone can help, thanks !

Product Version: UE 4.21
Tags:
more ▼

asked Mar 19 '19 at 10:37 AM in Packaging & Deployment

avatar image

tbeaugelin
62 2 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Try to play the game in editor, check Log file and there should be at least a clue showing where is the division.

more ▼

answered Mar 19 '19 at 10:44 AM

avatar image

Ego Studio
606 4 4 5

avatar image tbeaugelin Mar 19 '19 at 10:45 AM

Well that's the thing... Game log is clean in editor, and I got no error in standalone launch neither... EDIT: After testing all of our maps, I get no error in any of them.

avatar image Ego Studio Mar 19 '19 at 10:56 AM

You can also use search in BP with keyword : "integer / integer". This should track all of your divisions.

avatar image tbeaugelin Mar 19 '19 at 10:59 AM

Is there a way to do a search in all the blueprints ? Because we have a lot of them, and doing them one by one will be a pain in th a**... EDIT: We didn't had that much BP after all, seems like the project is cleaner than I thought. Anyway, funny thing, we do not have any single Int/Int in our project. Not a single one !... EDIT#2: after using the find in all bp, here is what i got with int/int : https://imgur.com/Mr1jVim

avatar image Ego Studio Mar 19 '19 at 11:04 AM

On the right of "Find in blueprint" there is a binoculars icon, this is Find In All Blueprints

avatar image Ego Studio Mar 19 '19 at 11:13 AM

Then you should check those 4 divisions one by one (it will take less than a minute) and fix it up EDIT : It's in-engine BP, do not change anything !

avatar image tbeaugelin Mar 19 '19 at 11:23 AM

I'm a now wondering, in my error message, it say INT_DIVIDE_BY_ZERO, so is it necessarly an Int/Int operation ? Could it come from any other Int division ?

EDIT: Nevermind, only int can divide int apparently...

avatar image Ego Studio Mar 19 '19 at 11:27 AM

Normally there is no Int/Float nor Int/Vector but the best thing to do is track all of your division. Mind to disable "Show engine content" in view options

avatar image Ego Studio Mar 19 '19 at 11:20 AM

Now looking close to your log, the problem seems to be caused by something else. Try to restart computer, delete all files from previous build inside the project, open the project and re-build.

avatar image tbeaugelin Mar 19 '19 at 12:03 PM

Yup. I tried on a different machine, and the game now works flawlessly. Weird, I'll see if restarting and deleting old files on the other computer actually do something, or if I'm doomed to use another machine. Anyway, thanks for taking the time to help me out !

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question