x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to remove Water Tiling Edges Showing

I am having an issue where the edge of my water tiles is showing the edge when setup next to one another.

Picture of issue:

alt text

Is there something I am missing to get these edges to disappear?
I used the river water texture from this asset pack: https://unrealengine.com/marketplace/en-US/water-materials

Thank you!

Product Version: UE 4.21
Tags:
more ▼

asked Mar 21 '19 at 04:19 AM in Using UE4

avatar image

Brad.
6 1 1

avatar image SupDeity Mar 21 '19 at 06:32 AM

:/ are you using the same actor for the whole water or different ones?

avatar image Brad. Mar 22 '19 at 12:23 AM

I am using a bunch of water planes and aligning them

avatar image SupDeity Mar 22 '19 at 11:18 AM

then that might be a issue. is there a specific reason u arent using the same water plane?

avatar image Brad. Mar 23 '19 at 01:42 AM

I am rather new to working in unreal. Is there any performance difference between making one large water plane and tiling them? I figured tiling them might be better but I may be wrong. Please let me know!

avatar image SupDeity Mar 26 '19 at 11:45 AM

i dont really think so there is really any difference but its just much better using one single one so you dont get issues like tilling.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

check if this works: open texture file, in the right hand side(thats where your options are), go to the texture area, click on the show more options arrow: and in x tiling and y tilling set it to clamp.

more ▼

answered Mar 21 '19 at 06:35 AM

avatar image

SupDeity
468 4 7 15

avatar image SupDeity Mar 22 '19 at 11:24 AM

its not in material, its in texture file. the texture files have a red underline on the image and when you hover over them it will say Texture in brackets after the file name. make sure you are opening water texture. in the file there will be a texture area right below Level of detail.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question