x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Master branch (v23.0) doesn't have structbox???

I've been trying to go around a nasty bug on official release version 4.21.2 which prevents me from compiling to iOS ( https://issues.unrealengine.com/issue/UE-70358) and since the fix is only available to version 4.22 it doesn't feature in the release branch. I've been trying therefore to use the Master branch.

However when I try to load my project it says that plugin structbox could not be found. I'm almost giving up on the hope that the release branch gets updated this Wednesday when hopefully 4.22.0 comes out, but aware that that may not happen, here is my question:

==> Does anyone know how to get structbox as a separate plugin within my project? Or how to add this absolutely essential plugin back in the master branch?

I normally don't get answers on those questions but remain hopeful...

Thanks...

Product Version: UE Github Master branch
Tags:
more ▼

asked Mar 25 '19 at 07:55 AM in Installation & Setup

avatar image

Al Ananias
247 6 10 18

avatar image Al Ananias Mar 26 '19 at 12:42 AM

Ok, I've edited the project file (.uproject) directly to disable to structbox plugin and it opened the project fine.

Tried to compile - fail, doesn't support bitcode. Fine. Disable bitcode.

Tried again - fail: "Code Signing Error: Provisioning profile "xxx" doesn't support the iCloud capability." (xxx is my project).

This is extremely frustrating. I'm sorry to say but the branch that is "extensively tested" is broken on something that is quite essential - there is not much one can do if one can't package the project. The bug is solved, but not for the current official released version!! That forces people like me to use the master branch which s pretty much useless since it is absolutely unstable.

Can I kindly suggest that perhaps someone could test key functionality such as remote compile before releasing a version into production? This would avoid a lot of time wastage and frustration.

Can I also kindly suggest that you keep working branches of each major version so that people can go roll back to an older version when you eff it up?

Finally can I kindly suggest that you update the current release when you fix a major bug that is fundamentally a showstopper for some workflows, or at least publish a workaround?

Three pretty basic things that surely wouldn't hurt. Would make our lives much easier and your engine much more attractive.

For now, I give up. Staff couldn't be bothered to answer my questions and engine is broken, so I'll just forget about it and wait for the next version. Time to research other options for the next project.

avatar image Al Ananias Mar 26 '19 at 08:25 AM

Ok, I managed to solve the problem on my own. Normally I would post how I solved it here but I had enough - about 38% of my questions are even answered, with the rest being either left unanswered or answered by me when I figure out the solution on my own.

I had enough. When I start receiving something back from the community, with answers to at least 50% of my questions, I'll start contributing again.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

If you'd still need a solution for your original question, according to a forum discussion (https://forums.unrealengine.com/unreal-engine/announcements-and-releases/1598851-unreal-engine-4-22-released?p=1609063#post1609063) you can just add the plugin from 4.21 to your project, rebuild it, and it should work. You'll have to maintain it on your own though.

more ▼

answered Apr 18 '19 at 10:24 AM

avatar image

KristofMorva
1.4k 5 5 7

avatar image Al Ananias Apr 19 '19 at 06:33 PM

Thanks Kristof. I gave up on the master branch and went back to the last engine version that was working for me. But this is helpful, now I know what to do if I decide to play around with the master branch again. Have a great weekend!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question