x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Critical Error is Crashing Editor

Using a slightly older engine version, but it should work. Here's the issue that's crashing the editor:

 [2019.03.29-13.42.39:998][170]LogMac: Assertion failed: Assertion failed: NewOperatorInputA [File:/Users/build/Build/++UE4+Release-4.16+Compile/Sync/Engine/Source/Editor/BlueprintGraph/Private/K2Node_CommutativeAssociativeBinaryOperator.cpp] [Line: 287] 

I get this issue anytime I try to open a map or blueprint.

This project is from Windows and I've migrated it over to Mac to get the Mac build up and running.

I am using the VictoryPlugin from Rama, and searching the log that XCode outputs (seen above), it seems as if its related to it. Since then I've attempted to disable it (same error occurs) and then also delete it entirely from the projects plugin folder. Same issue is still occurring. This issue, obviously, does not happen on Windows.

Any help into this would be greatly appreciated. Thank you!

UPDATE: After upgrading the project to 4.21, the error persists on Mac. I am still unsure what to do. It seems creating a new project and migrating the files over to it seems to work (can load up some blueprints), but I'd rather not do this if there is an actual solution since it means resetting up some code and other things.

Product Version: UE 4.16
Tags:
more ▼

asked Mar 29 '19 at 01:48 PM in Using UE4

avatar image

Higuy8000
178 11 11 28

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

SOLVED: The issue stemmed from the VictoryPlugin indeed.

The way I found out: After getting the project to at the very least open, I attempted packaging. This provided some additional information of where the error was occurring, which indeed used a function from the plugin. After I figured this out, I did more digging into the plugin itself.

The way I solved it: Turns out, the VictoryPlugin does not in its .uplugin have a whitelist for "Mac". Adding that in the whitelist, regenerating the xcode project files, and then rebuilding the project in Xcode fixed the issue.

more ▼

answered Apr 01 '19 at 10:06 PM

avatar image

Higuy8000
178 11 11 28

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question