x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Door opens in editor and "Standalone Game" but not in packaged build.

Hi,

For some reason there is a door to an elevator in my game that opens in the editor and the "Standalone Game" mode, but it won't open in the packaged build. I really don't know why it won't work in the packaged build. The elevator has a button that turns green and opens the doors when clicked, but for some reason in the packaged build it won't open.

Anyone have any ideas? I've been trying like crazy to get it to work, but nothing I do makes it work.

Thanks,

David

Product Version: UE 4.17
Tags:
more ▼

asked Apr 05 '19 at 10:49 PM in Packaging & Deployment

avatar image

davidtavern
1 1 1

avatar image davidtavern Apr 05 '19 at 11:39 PM

Also, I've been using the "Moveto" function to move the doors. I think that for some reason the "Moveto" function isn't working in the packaged build.

avatar image davidtavern Apr 06 '19 at 12:14 AM

The "Moveto" functions aren't causing it. For some reason my NPC References and First Person Char References aren't working properly in the build.

You can see in the screenshots below that I have a print string that prints that NPC Reference and First Person Char Reference are not valid when they are not valid. For some reason these two references are invalid in my packaged build.

Anyone have any idea to fix it?

Thanks,

David alt text

alt text

avatar image davidtavern Apr 06 '19 at 03:16 AM

Well, I made the NPCReference instance editable and put in an instance of the NPC and that one worked.

However, I tried to do the same thing for the First Person Character Reference and that didn't work, so now I'm stumped again.

avatar image davidtavern Apr 07 '19 at 01:14 AM

Anyone have any ideas why the door won't open?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question