x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to remove light entirely from the game

Hi! I've created a brand new, empty project and added a few sprites (it's a 2d game project) to the world. I've changed the DefaultSpriteMaterial's shading model to unlit.

In the viewport when pressing unlit option, everything works fine both in perspective view and in the front view. But when I switch to lit, even though there's no light in the scene, the perspective view adds a little bit of light on everything so the sprites look more brighter than the should (unlit in perspective works as expected).

When I launch my project it looks like in the perspective view and lit mode, that is, more brighter than it should be.

Is this because of some kind of post processing added on top of the sprites? Can it be disabled? How?

Product Version: UE 4.21
Tags:
more ▼

asked Apr 08 '19 at 02:36 PM in Using UE4

avatar image

Artlor
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi! Please check whether disabling AutoExposure for your new project fixes this (Edit>Project Settings>Rendering>Default Settings>Auto Exposure uncheck).

more ▼

answered Apr 08 '19 at 06:18 PM

avatar image

duderseb
503 2 9 7

avatar image Artlor Apr 08 '19 at 08:33 PM

Hi! I had it already unchecked. I'm afraid that's not the issue here.

avatar image duderseb Apr 09 '19 at 01:07 PM

Just in case, if you haven't already, there are a few more settings you can try disabling in that Rendering tab which could be contributing to this (Bloom, for instance). Failing that, I'd also check the World Settings for your level as well as the Post Process settings in the Camera.

avatar image Artlor Apr 30 '19 at 09:38 AM

That does not seem to work, unfortunately. The sprites in the viewport have a slightly different color (more darken now) than in the "play" mode. In the play mode the sprite seem to have also a little bit of vignette. I tried disabling it in post process volume, and in DefaultEngine.ini file but it still does not work (it still changes the lighting of my sprite).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question