x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Camera jumps behind my character

I don't know what happened that my camera started suddenly jump behind my player. I don't know where even to look for the solution. Can anyone help? I remember that prior to this bug I was playing the same character in the other level for promotional video. After I closed the project and opened it again, the problem with camera appeared.

https://www.youtube.com/watch?v=MGh0R-4CgSo&feature=youtu.be

Product Version: UE 4.21
Tags:
more ▼

asked Apr 11 '19 at 08:46 PM in Blueprint Scripting

avatar image

aabun
77 5 7 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Looks like a camera collision issue

more ▼

answered Apr 11 '19 at 09:33 PM

avatar image

skealeye
136 3 4 4

avatar image aabun Apr 11 '19 at 11:31 PM

Yes, it looks like this but I still have no idea where to go to check the problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I would test by turning off Camera collision. Im guessing u're using a springArm to move the camera, and i'm guessing u're probe channel on the arm is set to "Camera". Set the test collision objects to ignore the Camera Trace channel, this will allow ure camera to pass thru objects. Alternatively if u want collision off completely on camera u can turn off the bool for "Do Collision Test" on the spring arm.

I would also read up on how UE4 handles collision channels:

link text

best of luck!

more ▼

answered Apr 12 '19 at 01:05 AM

avatar image

skealeye
136 3 4 4

avatar image aabun Apr 12 '19 at 08:33 PM

"Do Collision Test" off - actually returned the player back to scenery, thank you! now I can't understand why my character started running way too fast than before. This is all strange, because I seemingly didn't do changes in this area. but i may be wrong and unwillingly changed something without noticing it. Anyways, I am hopeful now. Any suggestion where to look for - for the running like flying speed?

avatar image aabun Apr 12 '19 at 09:06 PM

I already posted a new question, but just in case here is the link to my new issue https://www.youtube.com/watch?v=gItosAY-VL4&feature=youtu.be

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question