x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Light maps/static shadows clipping?

Hi, I am really new to UE4 and I am struggling with getting my shadows/light maps to display correctly. I am using a single directional light set to stationary, a skylight set to static. When navigating in the scene the shadows are clipping too close to the camera. I have messed with cascade shadow distance but with no success. Does anyone have any advice or is there something I am missing? Please see images below:alt text

Product Version: UE 4.21
Tags:
more ▼

asked Apr 11 '19 at 10:53 PM in Rendering

avatar image

digtlpete
16 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Thank you! Those are great ideas. I will give it a shot. Thanks again for all of your help.

more ▼

answered Apr 20 '19 at 04:14 PM

avatar image

digtlpete
16 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi there! When I got you right, then this issue is because through the dynamic shadow distance Unreal is blending between your baked light and the cascaded shadow maps. When blending in between, you can see difference and the realtime shadows may be a bit off. You can also play around with the contact shadow length to fight artifacts like in your second picture: The contact shadows are adding better self-shadowing, the lit areas under the bridge should vanish when playing around with the values (not to big, not to low). I hope that helps! :)

more ▼

answered Apr 14 '19 at 09:10 AM

avatar image

Dividuum
10 2 3 7

avatar image digtlpete Apr 15 '19 at 01:07 PM

Hey Dividuum, I will give it a shot and let you know how it works out. Thanks for helping out!

avatar image digtlpete Apr 15 '19 at 05:50 PM

Hey Dividuum, adjusting contact shadows does help but it is now introducing a different problem by creating shadows on elements that are set to not cast shadows. Is there anyway to turn off contact shadows on certain objects?

alt text

avatar image Dividuum Apr 16 '19 at 06:30 AM

That's weird indeed... Are those strips meshes by themselves or are they just in the texture? If second: may you provide a look at the material graph? Otherwise, does finetuning help? I know it is a thin line between good results and artifacts from that value.

avatar image digtlpete Apr 17 '19 at 03:06 AM

The stripes are geometry. I have shadow casting turned off, but when I enable the contact shadows that is what I get. The floating stripes are the easiest way to do them. If I set them too close to the road surface they will sometimes sink below. I can't seem to find a way to turn off contact shadows for individual objects. I did render my lighting with higher settings which seems to help some.

avatar image digtlpete Apr 17 '19 at 03:09 AM

The contact shadows is a great fix for still images, but for animation, I am getting some buzzing in certain areas. I see what you're saying about fine-tuning. Thanks for all of your help!!

avatar image Dividuum Apr 17 '19 at 06:24 AM

Alright, I thought they were seperate geometry. Well, I think that making them seperate geo is probably not the best solution, if that was my scene, I would have included them into the street material. Either in the basic textures, or through layering them in the material on top of the original one.

I would have two solutions in mind: 1. change the strip materials to decal - therefore you could use them as a mesh decal, I believe they should not have those artifacts then - but I am not certain! 2. Maybe (this solution is a bit more messy) you could make a second directional light, that uses light channel 2. You put your strips on light channel 2. Then you deactivate the contact shadows on the light channel 2 lights. This could work, but as I said is not a clean solution: With every light change, you would have to copy all the changed values from light A to B. And I am not certain if the rendering gets more complicated.

IMO, the best way would still be to remove the geometry and include the strips into the material. Hope that helps you, Felix

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question