x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

After reboot my computer, none of the saved maps works.

Yesterday I saved the project with the map and I shutdown my computer. Next day, when i opened my project, I got this message: "Assertion failed: Existing.Linker->ExportMap[Existing.LinkerIndex].Object==this [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectLinker.cpp] [Line: 107]". If I try open my map from the backup, I'll get message: "Failed to load assets". Also I created a new project with this content but I got the same effect. Can you help me? Thank you in advance! If you want a screenshot, just say.

Product Version: UE 4.20
Tags:
more ▼

asked Apr 12 '19 at 10:39 AM in Using UE4

avatar image

Razorek
1 2 3

avatar image TheCreator1337 Apr 17 '19 at 08:02 AM

I've been having the exact same error. If you ever find a solution to your problem, please, please, please, post it here!! (My engine version is 4.22 though)

avatar image Razorek Apr 17 '19 at 09:08 AM

You know what? You can solve your problem only by restoring the system ;-( Unfortunately, I don't have restore point..

avatar image Razorek Apr 17 '19 at 09:10 AM

We can talk about this in a private message If you want

avatar image TheCreator1337 Apr 17 '19 at 02:49 PM

I have a backup of my project from 2 days ago working without problem, but I don't know what exactly is causing the problem. Having to restore my system would suck tho

avatar image FinalZer0 Apr 17 '19 at 03:00 PM

Is your project C++ project? If so then did you forget to press "compile" button? It might be because your assets parent objects are corrupted or not compiled, and it affects all your child classes, including those in your level.

avatar image Widzo Apr 17 '19 at 07:38 PM

Hey, i have the exact same issue today, i can't open my main project anymore but i can open others projects.. Did you found a solution?

avatar image Blackforcedragon Apr 17 '19 at 07:39 PM

did you delete any C++ file?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

try to build the light and press the save all

more ▼

answered Apr 12 '19 at 02:12 PM

avatar image

Blackforcedragon
0 3 8 12

avatar image Razorek Apr 12 '19 at 03:18 PM

Unfortunately I can't do this because I can't load my map ;-(

avatar image Razorek Apr 12 '19 at 03:19 PM

But thanks for answer ;-D

avatar image Razorek Apr 12 '19 at 03:25 PM

Also I can add that I have never builded the light. Is this wrong?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You can try to update your grapic card and see if that will help, if that don't work it can be a bug in Unreal or bad memry

more ▼

answered Apr 17 '19 at 02:53 PM

avatar image

Blackforcedragon
0 3 8 12

avatar image Razorek Apr 17 '19 at 03:24 PM

Do you think my graphics card is broken?

avatar image Blackforcedragon Apr 17 '19 at 03:25 PM

no, but you can try to update it

avatar image Razorek Apr 17 '19 at 03:29 PM

I haven't got any update ;-(

avatar image Blackforcedragon Apr 17 '19 at 03:31 PM

you need to use the software Nvidia Geforce Experience to update your graphics card

avatar image Blackforcedragon Apr 17 '19 at 03:33 PM

Sorry, I did misunderstand what you did say

avatar image Razorek Apr 17 '19 at 03:34 PM

I have got Driver Booster 4 PRO. Can't this be?

avatar image Blackforcedragon Apr 17 '19 at 03:41 PM

Driver Booster 4 Pro is a third party software, some of the third party softwares will not give you the latest updates. You can try Nvidias software or you can try Nvidias website to get the latest update. Here is a link: https://www.geforce.com/drivers

avatar image Razorek Apr 17 '19 at 03:46 PM

Ok, I try download it ;-D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I found a solution that worked for me, following these steps :

-Duplicate your whole project so you don't modify your main project directly.

-Open the copy directory, open folder Content

-Move the assets you suspect to make your editor crash in another folder (move them to Desktop is fine, for me it was Widget, so i moved the widget.uasset to my desktop)

-Then try to open your project, if it don't crash you can start to replace your assets one by one until this crash again, this way you can isolate the asset make your editor crash and replace it by an older version of the asset (if you have a save) or recreate it.

Hope this help ;)

more ▼

answered Apr 17 '19 at 09:28 PM

avatar image

Widzo
53 3 4

avatar image Razorek Apr 17 '19 at 09:49 PM

But even the oldest backup map isn't working

avatar image FinalZer0 Apr 18 '19 at 06:27 AM
  1. Open Config/DefaultEngine.ini and empty value of "EditorStartupMap"

  2. Open your project

  3. One of your assets on map is corrupted, find it and rewrite it.

  4. Continue with your project...

  5. ????

  6. Profit

avatar image TheCreator1337 Apr 18 '19 at 10:18 AM

Thank you for that helpful tip! I can now open my project again, but it crashes whenever I hit play and sometimes when I compile, which makes it difficult to deduce what is causing the game to crash. I did manage to get an error that said that I was accessing an index of an array that didn't exist, so let's see where that leads.

avatar image Razorek Apr 18 '19 at 11:54 AM

Every file uasset is working but files unmap isn't working

avatar image Razorek Apr 18 '19 at 11:59 AM

Do you have Skype or TeamViewer? I show you what is wrong

avatar image TheCreator1337 Apr 18 '19 at 08:03 PM

I have Discord.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Have you found any clear reason why this is happening?

It has happened twice to my project this week.

On the first time I found that it was caused by three UI's. I removed and remade them, and the problem went away.

Today I restarted the editor and this issue came back. Luckily I had a just commited to my version control software and was able to roll back.

more ▼

answered Aug 13 '19 at 09:02 PM

avatar image

villehappo
3 1 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question