x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why won't my game build? Unknown Cook Failure

So I've been working on this game everyday for many months just to find out i can't build it.. ='( I was hoping to build the game before a gamedev meeting tomorrow but that doesn't look like it's gonna happen. This is my first time building a project and all this looks extremely overwhelming and hopeless. I'm not even sure what the best way to to present the information here. I screenshot all the red portions. and pasted them into an image. Please let me know what to do from here

alt text

-What I did so far Open each level and run a map check Right Click on the Contents folder in the Content Browser and select "fix up redirectors in folder" Delete the Intermediate and Saved folders from the project folder Re-Save the project

Product Version: UE 4.21
Tags:
more ▼

asked Apr 12 '19 at 05:47 PM in Packaging & Deployment

avatar image

TronixGameDev
8 1 3

avatar image TronixGameDev Apr 18 '19 at 01:37 AM

Anyone? even just how to fix some of them would help.

avatar image Blackforcedragon Apr 18 '19 at 01:06 PM

It look like you are trying to build the game, and convert blueprints to c++, try to disable the Blueprint Nativization Method and try to build the game again

avatar image TronixGameDev Apr 19 '19 at 03:18 AM

This one? looks like it was already disabled

alt text

blueprintnav.jpg (20.1 kB)
avatar image TronixGameDev Apr 19 '19 at 03:30 AM

Some people on FB suggest to relocated the project/build onto the c drive, for the filename errors. And another suggested to turn off the plugins. It got some errors out. Here's what it looks like now

alt text

avatar image TronixGameDev Apr 19 '19 at 09:22 AM

The doesn't exist files needed to be deleted in the directory. It was already deleted in UE4.

the unknown structure errors was a bug someone else had had. I just needed to resave the files.

Here's whats left

alt text

avatar image teak421 Apr 20 '19 at 06:57 AM

In your project settings under packaging, your not excluding any important directories / content / maps?

avatar image TronixGameDev Apr 21 '19 at 03:28 AM

no I haven't tried excluding anything

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I think you UE4ASP_HeroTPP_AnimBlueprint is the problem,you can try to remove it and try build the game

more ▼

answered Apr 19 '19 at 10:36 AM

avatar image

Blackforcedragon
0 2 8 10

avatar image TronixGameDev Apr 20 '19 at 06:05 AM

I tried deleting UE4ASP_HeroTPP_AnimBlueprint and it didn't change anything. I'm still getting the same exact errors reffing to it as if it was still there. I even tried deleting the saved and intermediate folder again and rebuilding and got the same result

avatar image TronixGameDev Apr 21 '19 at 08:10 AM

I think it is looking for a deleted class of the same name, but I've tried making a new cast nodes and deleting the old ones. I tried fixing up redirectors, I haven't excluded anything from packaging, I even tried making a new project and transferred the contents folder over (both copying and pasting and migrating) hoping that would fix the redirectors, I tried deleting the AnimBP

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question