x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Attaching Item to Socket

Ok. I've been similar questions, but none of the answers worked for me. I've been stuck on this for about 10 hours now and had to post this question.

I have an item in the world for the player to pickup. When the item is picked up it goes into their inventory. The user can then click on the item in the inventory widget which fires an OnUsed event. This is where I am running into problems, The event fires correctly and in my BP_Pickup_Axe blueprint class I am trying to attach the picked up item's mesh into the players hand where I created a socket named weapon. I've tried countless versions of this same blueprint and half the time nothing at all happened. I am now able to see the weapon in the users hand, but my character is now glitched. The character is thrown into the air and a lot of other issues when the user is back on ground.

What am I doing wrong here?

BP_Pickup_Axe alt text

Product Version: UE 4.22
Tags:
bp-pickupaxe.jpg (133.9 kB)
pickupglitch.jpg (110.8 kB)
more ▼

asked Apr 14 '19 at 07:34 PM in Blueprint Scripting

avatar image

TX Nuno
1 1

avatar image TX Nuno Apr 15 '19 at 01:08 PM

Ok. I finally got it working. I needed to Set Actor Enable Collision to false after attaching the item.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The character is thrown into the air

that sounds like a collision issue. try disabling the collision on the axe when its spawned.

you may also want to try a cast to the characters class before getting the mesh, its probably not needed but its something to check out. it should try to get the socket and if the character doesnt have one then just attach at the character origin but who knows sometimes.

more ▼

answered Apr 14 '19 at 10:01 PM

avatar image

ThompsonN13
10.1k 33 9 23

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question