x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Simple Spline problem

Hello ppl, I have a problem while using simple splines that has me very confused. I created a spline BP in which I have a public variable for the mesh that way I can drag and drop meshes in there to use as a spline. It works... for some meshes and I dunno why. For example I created a simple hollow tube and it works fine but then I cut the same tube in half to form a sort of half-pipe (like for skaters) and all of the sudden I can't use that mesh in the spline. The importing method was the same and no changes done aside from the mesh it self. Many other static meshes work with the spline while many others don't.

Any ideas on why this is happening? Or is there a way to prepare a mesh to be used specifically for splines?

Product Version: UE 4.22
Tags:
more ▼

asked Apr 16 '19 at 03:30 AM in Blueprint Scripting

avatar image

D4njo
6 4 7 10

avatar image ThompsonN13 Apr 16 '19 at 01:29 PM

is it giving you any kind of error message? what is it actually doing when you try the halfpipe? does it show at all?

avatar image D4njo Apr 17 '19 at 01:43 AM

No error messages or anything I drag a mesh in the according slot and it just doesn't show at all. I do the same for some other meshes and they show up and work so it's a mystery why it won't take the half pipe.

avatar image IndieGameCove Apr 17 '19 at 02:23 AM

one thing you could check, by dragging the half pipe into the level, is just that the pivot point is at the center or base of the mesh. If for some reason the pivot is off your mesh may just be offset somewhere you didn't notice.

Could also be a bounds issue I guess.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question