x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging UE4 Project Results In Failure, shows "Corrupt data" Error

I am trying to package a playable demo of my game. Every attempt so far gives an error that says "Corrupt data found, please verify your installation**."

alt text

I am using Unreal Engine 4.18.3, it has already been verified. No change in error. I even tried deleting the "Saved" and "Intermediate" folders. Nothing different, still get the same error. I am only using Blueprints and no C++ code if that helps. I am using Windows 10 on a 64-bit system, but trying to package this small scale demo as 32-bit so more systems can run it.

I will say that I think I might know what the issue is but I don't know if this is the cause: I have this issue with my project where it's trying to find some material files, but they're being referenced by Blueprints that don't even exist anymore, they've been deleted through the engine and they aren't being referenced by anything. Could this be the issue for the Corrupt Data Found?

alt text

alt text

As you can see here, errors that reference the old materials "jetpac1_Mat" and "jetpac2_Mat" don't even exist at all, the folder only contains a completely different texture that's being used for particle effects called "hit_circle_effect" which has no errors. What puzzles me even more are problems like "Enforcer_Skeleton_AnimBlueprint" never even used the "jetpac2_Mat" material, but it still tells that it can't find the file. The Enforcer and the Unikorch enemy types (Blueprints) do not share any materials nor ever have. The blueprint "Unikorch_Jetpack" was also manually deleted too just before i reopened up the project to get the same error. What is going on?

I can try running the packaging again and copy-paste the entire readout onto a google document if that helps too, maybe there's a really simple error/problem that I just can't find? Any suggestions would be great help!

Product Version: UE 4.18
Tags:
erros.png (70.2 kB)
error-proof.png (7.4 kB)
error1.png (3.5 kB)
more ▼

asked Apr 17 '19 at 04:40 AM in Packaging & Deployment

avatar image

GuyPagani
1 1 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question