x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging Project: Error missing precompiled manifest for plugin

I am experiencing an issue packaging a project that uses a code plugin I also created.

The steps I have taken are as follows:

  • Created a project

  • Created a project plugin within that project, and developed the plugin

  • Set plugin platform whitelist to Win32 and Win64

  • Confirmed plugin compiles correctly by compiling all platforms in VS, and packaging the plugin in the editor

  • Copied the plugin into Engine/Plugins/Runtime

  • Edited the uplugin file, set engine version and Installed to true

  • Created another project (examples project), enabled the custom plugin

  • Created content in the examples project that uses objects from the code plugin

  • Tested content as working correctly in PIE

  • Successfully cooked examples project in windows

However, when I attempted to package the examples project itself, I receive the following error:

ERROR: Missing precompiled manifest for 'TestPlugin'. This module was most likely not flagged for being included in a precompiled build - set 'PrecompileForTargets = PrecompileTargetsType.Any;' in TestPlugin.build.cs to override

I am unable to resolve this problem.

I tried adding 'PrecompileForTargets = PrecompileTargetsType.Any' into the plugin build cs file, but it didn't make any difference. The uproject file for the example does list the plugin in the Plugins section, which is set to enabled. The uplugin file defines the plugin module, sets the type to runtime, sets loading phase to default, and has the whitelisted platforms.

I am unable to find any other threads regarding "precompiled manifest" other than this one (https://answers.unrealengine.com/questions/887786/view.html), but that doesn't resolve my problem, because the plugin is already included in the example project.

Has anyone else experienced this issue and know how to resolve it?

Product Version: UE 4.22
Tags:
more ▼

asked Apr 19 '19 at 04:05 AM in Packaging & Deployment

avatar image

DeliciousWhales
21 2 3 4

avatar image INTUITIVE SVS May 08 '19 at 02:21 PM

Wish I could help, but I want to say that I have experienced the same thing as well.

I will let you know if I figure anything out today.

avatar image roushenzo May 14 '19 at 04:00 PM

Hi! And i have this problem...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I had the same issue when I tried to package for Linux. I fixed it by copying the plugin in the project folder (it may need to be in both folders).

I hope it'll help you.

more ▼

answered May 23 '19 at 08:39 AM

avatar image

LaZeKler
26 1 4

avatar image El-Magic16 Jun 04 '19 at 04:02 AM

Yep, that worked for me! We shouldn't have to do that anyway, really stupid.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question