x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Compiling Shaders: Freeze

Version: 4.21.2

Hello, I hope my problem is an easy one cause I would really love a fix till tomorrow (there is a birthday party and I coded a birthday riddle for it. I have already packaged a very simple project before (very small) so the general idea how to do it is not new to me. I can build lightning, geometry and everything. Map check doesn't return any errors. I get a lot of warnings in the log (I dont know which ones are relevant and they are sure too many to post them all here but I guess an example might help): UATHelper: Packaging (Windows (64-bit)): LogUObjectGlobals: Warning: Failed to load '/Game/Meshes/Assets/Peripherals/MouseMat/MouseMat3': Can't find file for asset '/Game/Meshes/Assets/Peripherals/MouseMat/MouseMat3' while loading NULL. UATHelper: Packaging (Windows (64-bit)): LogLinker: Warning: Can't find file '/Game/Meshes/Assets/Peripherals/Keyboard/Keyboard2' UATHelper: Packaging (Windows (64-bit)): LogUObjectGlobals: Warning: Failed to load '/Game/Meshes/Assets/Peripherals/Keyboard/Keyboard2': Can't find file '/Game/Meshes/Assets/Peripherals/Keyboard/Keyboard2'

What happens? It starts packaging but when it comes to compiling the shaders it stops making progress. Even after long periods of time you can see no change.

Im very willing to give all additional information needed and very happy if someone knows some wizard tricks to get around this problem. I wrapped my head around it for like 3 hours now and I just cant see it. Keep in mind that I am very new to Unreal Engine so it might be a beginner mistake.

What will I do now? I will copy the project and remove as many files as I can seeing when it packages properly

Product Version: UE 4.21
Tags:
more ▼

asked Apr 19 '19 at 08:48 PM in Packaging & Deployment

avatar image

MadShagMike
1 1

avatar image MadShagMike Apr 19 '19 at 08:48 PM

I have tried the following (not working): Deleted: Save and Intermediate Folder Removed files I manually imported into the project (not market place)

Working: Creating a new sample projekt and building it.

I have: Checked that Chunks are disabled

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question