x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Get All Actors with Tag doesn't seem to get all actors with tag

Hello !

What I am trying to achieve is basically to have a triggerbox that activates nearby enemies when the player walks in.

The enemies have a common tag (an Actor tag !) named ActivateTrapRight. However, when the event is triggered, I only seem to be able to get references to Actors from a single class in my array. I have two different classes of enemies with that tag and I expect to get them both in the array. I made a 1 minute video to demonstrate the problem as it is easier to show this way rather than adding myriad of screenshots.

(I basically explain the same thing in the video if you have sound)

https://www.youtube.com/watch?v=anGu9-14628

You can see that both have the same actor tags and that I only get one of both enemies in my array.

Do you have any idea what could be wrong here ?

Thank you very much for your time ! :)

Product Version: UE 4.21
Tags:
more ▼

asked Apr 20 '19 at 03:02 PM in Blueprint Scripting

avatar image

N0rgannon
41 1 2 4

avatar image N0rgannon Apr 20 '19 at 03:21 PM

I tried to bypass my issue by using Get All Actors Of Class instead in the meantime. For one of the class the Actor Has Tag node always return false. It works fine for the other class though. Why wouldn't it work for a class when it works for the other ? I guess there is a property somewhere that should be switched for the class that doesn't respond well to tags but I can't find what it is.

avatar image N0rgannon Apr 20 '19 at 03:34 PM

To sum up, the Actor tags of one of my classes seem to be ignored. Why could that be ?

(The class for which the tags are not ignored was created yesterday by copy pasting basically the class for which it doesn't work. So that makes absolutely no sense to me why they would have different behaviours.)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question