x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Spawn Actor From Class Node does not have collision.

When I spawn an Actor BP using the Spawn Actor Class node, the actor does not have collision. When I manually place that same BP into the scene, there is collision. Obviously, they have the same collision settings.

Product Version: UE 4.20
Tags:
more ▼

asked Apr 22 '19 at 08:43 PM in Using UE4

avatar image

Doctor_Kannon
216 4 4 11

avatar image Everynone Apr 22 '19 at 10:02 PM

How are you testing this collision? Can you show an example? To be clear, I've yet to experience something like that.

The Spawn Actor from Class node has collision override setting enumerator exposed by default - perhaps that's causing the confusion here.

avatar image Doctor_Kannon Apr 22 '19 at 10:10 PM

As I understand it, the Override is only for spawning. As gameplay continues, the spawned actor should have a collision box. It does not.

I'm using the Console Command, "pxvis collision 1" to test. The spawned actor does not have a visible collision box (neither auto-generated, nor UCX). The manually placed actor does have a visible collision box.

Edit 1: I cannot show the current example. Sorry. I'll see if I can repo by other means.

Edit 2: Actually, in a basic test scene, it works as expected. In the actual dev scene, it does not. Part of this frustration is that the issue appeared after collision had been working (was not backed up).

avatar image Doctor_Kannon Apr 23 '19 at 01:11 AM

I managed to get collision working again. To do this, I wiped out the BP nodes for spawning and simply replaced them with identical nodes (strange, ik).

However, the spawned collision boxes are still not visible with "pxvis..."

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question