x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Missing App Store Icon IOS

Hi, I am having issue with my packaged .ipa project. When I try to upload it via Application Loader, I get an error saying "missing info.plist value 'CFBundleIconName'. However, I've already set the marketing icon in my project, also tried generating xcode files and set the marketing icon there. No matter what I try it keep popping me with this error. It appears to me this is something related to 4.22. Because I already have an accepted version of the app. And I have no chance to roll it back to older unreal versions. Thanks in advance.

alt text

alt text

Product Version: UE 4.22
Tags:
more ▼

asked Apr 24 '19 at 09:38 AM in Packaging & Deployment

avatar image

HakanErunsal
44 3 8 12

avatar image HakanErunsal Apr 25 '19 at 03:11 PM

Edit: Just tried building a project with 4.19 and trying to push it through application loader. It gives out the same error. Could be something related to xcode version. Still waiting for a solution though.

avatar image RapidBlaze Jun 04 '19 at 03:13 PM

4.22.1 still have this issue. Package shipping for distribution build right now, have this trouble.

Fixed! UE-73066 iOS app icons appear blank on device for C++ projects packaged from Mac - not fix this.

avatar image KonZhukov Jun 11 '19 at 07:03 AM

Same issue here, UE 4.22.1, Xcode 10.2 Do anyone have some kind of workaround?

avatar image RapidBlaze Jun 11 '19 at 07:35 AM

I send to epic bug report about this issue. https://issues.unrealengine.com/issue/UE-50162 Vote please

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Changed macbook air to macbook pro and installed xcode 10.1 with UE 4.19. Now it's fixed. No more error. I can upload it to app store and it passes the review.

more ▼

answered May 02 '19 at 02:40 PM

avatar image

HakanErunsal
44 3 8 12

avatar image Elvince Jun 04 '19 at 08:16 PM

Did you finally successfully built it on 4.22?

avatar image RapidBlaze Jun 05 '19 at 09:47 AM

It does not work for me on version 4.22.1 of the launcher.

avatar image Elvince Jun 06 '19 at 03:01 PM

They have reopened a old case to track this bug: https://issues.unrealengine.com/issue/UE-50162 Please vote for it to get it fixed.

avatar image Täysikuu Jun 13 '19 at 03:32 PM

Same problem here with UE4.22.2. Project is built on a W10 pc through the UE4 remote build process. 13" retina MacBook Pro from late 2015 as a compiling server running Mojave (10.14.4) with XCode 10.2.1.

avatar image Ghar Jul 15 '19 at 05:15 PM

Same here. Remote building on Windows. Using 4.22.3

Everyone vote for them to fix it!

avatar image B REX Jul 16 '19 at 04:41 PM

Hi guys, after countless hours of frustration, I finally found a workaround!!!

You have to go to project settings -> iOS -> Additional Plist Data and add the following:

 <key>CFBundleIcons</key><dict><key>CFBundlePrimaryIcon</key><dict><key>CFBundleIconName</key><string>AppIcon</string><key>CFBundleIconFiles</key><array><string>AppIcon20x20</string><string>AppIcon29x29</string><string>AppIcon40x40</string><string>AppIcon60x60</string></array></dict></dict><key>CFBundleIcons~ipad</key><dict><key>CFBundlePrimaryIcon</key><dict><key>CFBundleIconName</key><string>AppIcon</string><key>CFBundleIconFiles</key><array><string>AppIcon20x20</string><string>AppIcon29x29</string><string>AppIcon40x40</string><string>AppIcon60x60</string><string>AppIcon76x76</string><string>AppIcon83.5x83.5</string></array></dict></dict>

Be sure to insert it without any new lines. Thats it. With this plist modification it can be uploaded after building.

In case you have an override for ios in Config/IOS/IOSEngine.ini look for [/Script/IOSRuntimeSettings.IOSRuntimeSettings] AdditionalPlistData= ... And replace or add the ... with the line from above.

Hope that helps you to also fix the mess.

avatar image Ghar 6 days ago

It worked! I was able to upload to the app store successfully. Thanks!

avatar image HakanErunsal 6 days ago

This solves it on 4.22.3. Thanks. I can't believe how epic doesn't help in any way about this.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question