x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Build error Plugin does not contain the module, but it lists it

So, I'm not really sure what happened. I packaged the game before, and didn't have this issue, but I've added a lot to it now, and it wont package. This is the error I'm getting. I've tried uninstalling, and reinstalling the plugin to the engine, but that did nothing. I saw someone on a similar thread say to install it to the project, but it looks like it already is. Any ideas what could be causing this issue? Thanks.

UATHelper: Packaging (Windows (64-bit)): ERROR: Plugin 'DirGravity' (referenced via GravityGame2.uproject) does not contain the 'DirGravity' module, but lists it in 'F:\UE4 Projects\GravityGame2\Plugins\DirGravity\DirGravity.uplugin'.

Product Version: UE 4.21
Tags:
more ▼

asked Apr 26 '19 at 10:31 PM in Packaging & Deployment

avatar image

Sociopath C-137
7 1 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

My wild guess is that this plugin don't have binaries to build configuration you trying to make and on that platform and you don't have Visual Studio installed to build it yourself.

Check in /Binaries and /Intermediate/Build in plugin directory if you got one corresponding to your build configuration and platform, if not you will need to install Visual Studio (or corresponding build tools for target platfrom), optionally contact author of the plugin.

more ▼

answered Apr 26 '19 at 11:44 PM

avatar image

Shadowriver
36.6k 931 169 1111

avatar image Sociopath C-137 Apr 27 '19 at 12:29 AM

Not that I 100% know what I'm looking for, but it looks fine to me. There is a /binaries, and /intermediate/build folder, each with the Win64 folder, with items in them. I do have Visual Studio installed, but I'm not the least bit familiar with it.

It may be worth mentioning that I have cloned the file, and thus renamed it, so maybe that has something to do with this issue? I strictly use blueprints, and I don't think it affects those at all, but maybe it affects the plugins?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Still don't know what was wrong. But I cloned it again, opened the folder containing all the files, deleted everything I figured I could get away with deleting. Re-opened the project, and used to clone as a reference to fix a bunch of blueprint errors. Now it packages fine again.

more ▼

answered Apr 27 '19 at 02:11 PM

avatar image

Sociopath C-137
7 1 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question