x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

When you click on the button there is no action (widget interaction for VR)

I am using UE version 4.19. When I try to press a button in a 3D widget using the widget interaction (red line), the button does not respond to a click. But the click reacts to the 2D widget that is not visible and takes up all screen space. https://pp.userapi.com/c853516/v853516847/2f79a/DScDojiZ9dE.jpg https://pp.userapi.com/c853516/v853516847/2f7b4/QnMlpobKLlM.jpg https://pp.userapi.com/c853516/v853516847/2f7be/4o3NGHFb30A.jpg Tried the methods described here: https://answers.unrealengine.com/questions/813093/view.html https://answers.unrealengine.com/questions/812884/3d-widget-input-not-working-in-ue-4201.html did not help me I hope the pictures will help in finding the error that I did not find

Product Version: UE 4.19
Tags:
more ▼

asked Apr 28 '19 at 07:23 AM in VR

avatar image

ДИЗпро
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi ДИЗпро,

I recommend changing the left mouse event that you have connected to the press pointer key nodes in your third link to be the VR controller button event you are useing to trigger it. Keep the pointer key nodes as they are.

If that doesn't help try moving the widget interact Infront of any objects the hand might have. It's possible there maybe collision in the way such as the hands or the sphere you have.

Hope this helps. Jonathan B

more ▼

answered Apr 28 '19 at 09:18 AM

avatar image

jonathan9232
81 5 4

avatar image ДИЗпро Apr 29 '19 at 03:14 PM

Hello Jonathan B I tried your recommendation, but I didn’t manage to do it as it should, apparently the problem is that the 2D widget is rendered covertly and does not allow to handle the process of clicking on the 3D widget, probably there is a way to fix it and it’s not complicated, but I don’t get it. I can throw off a sample project where you can try to fix it, if it doesn’t make it difficult for you!

avatar image jonathan9232 Apr 29 '19 at 03:25 PM

Hi ДИЗпро,

Yeah if you can provide a download link I can take a look at.

avatar image ДИЗпро Apr 29 '19 at 04:43 PM
avatar image jonathan9232 Apr 30 '19 at 10:11 AM

Thanks for sending the link I've opened it up and I'm looking at it now. What platform are you aiming this project for?

avatar image ДИЗпро Apr 30 '19 at 12:31 PM

Unreal Engine 4.19 for mobile VR app thanks for the help

avatar image jonathan9232 May 01 '19 at 10:03 AM

I've had a look at the project but I'm a little confused at what is meant to be happening in it are you trying to store the colour picked and then apply it or do something else?. Because the interactions seem to be working in mine. The 2D and 3D widgets are getting pressed.

avatar image ДИЗпро May 01 '19 at 12:47 PM

2D widget works correctly, but 3D widget does not work correctly, it reads information from 2D widget and when pressed with the help of an interactive widget, a completely different button is pressed

avatar image ДИЗпро May 03 '19 at 05:08 AM

I forgot to say that you understood the logic correctly. I'm just trying to understand the engine using such a set of functions. maybe there is another way to solve this problem in other ways, it was just the first thing that occurred to me

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question