x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

My landscape dissapears when in game view or in play mode but is visible in editor please help.

Recently whenever I click on play my landscape turns invisible but the collision is still there, I don't know what's causing this, and by the way "hide in game" isn't toggled on, please help.

alt text

alt text

Product Version: UE 4.22
Tags:
more ▼

asked Apr 28 '19 at 08:12 PM in Using UE4

avatar image

Noah04082002
3 1 1

avatar image S3B3ST Apr 28 '19 at 08:43 PM

Had the same bug a while ago, I still have no idea how this could happen...

avatar image Noah04082002 Apr 28 '19 at 08:46 PM

Did you fix it? Is there any workaround or anything?

avatar image DonBusso Apr 28 '19 at 08:53 PM

Hello,

I've done some research and some of the things I found

  • try re-opening the engine

  • check the default settings as shown on the screenshot below (play around with Desired Max Draw Distance

  • switch your quality settings to epic

alt text

Hope this will be of some help. Good luck

avatar image Noah04082002 Apr 28 '19 at 09:03 PM

Thanks for the reply and suggestion, I just tried what you said and unfortunately, it did not work my landscape still disappears.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I was playing around with it just now, changed the Desired Max Draw Distance then changed it back to 0 and it did disappear. Couldn't get to show again. Trying to replicate it now.

Edit: See if you get the same result when you press play for: Selected Viewport/NewEditorWindow(PIE) and Simulate

alt text

You can also read this one: https://answers.unrealengine.com/questions/861995/my-landscape-disappears-when-in-standalone-mode.html

more ▼

answered Apr 28 '19 at 09:17 PM

avatar image

DonBusso
507 3 5 6

avatar image Noah04082002 Apr 28 '19 at 10:50 PM

I remember that when I pressed simulate, my landscape was visible but when I possessed my character it disappeared, as for the other suggestions I’ll try them out when I've got the time and I'll tell you if it resolves my problem.

avatar image DonBusso Apr 28 '19 at 10:53 PM

At least it's something. It would be great if you could post a solution over here if you find one, I'm following this topic. I will try to give it another go tomorrow, there is a solution and it's probably going to be something ridiculously simple.

avatar image Noah04082002 Apr 29 '19 at 05:19 AM

Resampling the landscape did the trick now everything works fine, thanks a lot for taking the time to respond.

avatar image DonBusso Apr 29 '19 at 07:12 AM

My pleasure. Always happy to help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question