x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Random lag in editor while playing level

Hi. Recently, I've been experiencing problems while testing my game (by playing in the viewport) in which the game would randomly start to slow down and lag like crazy, almost completely freezing. It'd take a few seconds for the game to even stop after I'd press ESC or the stop button. I've watched my task manager while this happens and I noticed that the CPU and GPU usage drops dramatically when this is happening - similar to the behavior when the engine is unfocused perhaps? Although I can't figure out what's causing this as it seems to happen at a completely random time. I've also noticed that sometimes only the background music I have in my level "lags", and moving over a UI element (hover sounds)/making any other sound stops this behavior for the amount of time this sound plays and then starts to lag again. Both of these two situations seem to happen randomly with no apparent cause on my end, and because of the strikingly similar behavior to how the editor reduces CPU and GPU usage when unfocused I don't think it's my game that's causing the slowdown. Could anyone provide some help/insight into why this is happening/any further info I could provide?

I'm working on my first legitimate UE4 project - and this is my first post here, so if I missed another answer similar to my situation here or something like that I apologize.

Product Version: UE 4.22
Tags:
more ▼

asked May 01 '19 at 02:08 AM in Using UE4

avatar image

TheSinkGod
1

avatar image StaticJPL May 17 '19 at 10:44 AM

I'm having issues as well with the editor. I'm noticing the editor runs slow as if in slow motion. I checked my resources and my CPU is less than 13 percent and GPU at around 60 percent. I am curious why this is?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question