x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Is UE-73159 supposed to be closed as "By Design" ?

Hello,

We are using a Blutility that is pretty similar to the one mentioned in UE-73159. When upgrading our Engine from 4.21 to 4.22 I noticed our Blutility wasn't compiling anymore.

I tested a Blutility inheriting straight from UGlobalEditorUtilityBase and it worked fine, but a Blutility inheriting from a C++ class itself inheriting from UGlobalEditorUtilityBase doesn't has access to functions such as "For Each Selected Actor".

It used to work in 4.21. Is this behavior really intended ? And if so, what is the reasoning behind it ?

Thank you.

Product Version: UE 4.22
Tags:
more ▼

asked May 02 '19 at 12:51 PM in Bug Reports

avatar image

Francois.Bogaert
6 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Francois,

I checked the internal report and there was a comment that explains why this is marked by design. I edited the report to add that as a public comment on the public issue tracker, after a bit of editing, but this is the comment:

"The user's plugin is currently a Developer plugin, which means it can also run at runtime.

If they make the plugin an Editor plugin, they will be able to compile."

I hope this helps!

more ▼

answered May 02 '19 at 06:10 PM

avatar image Francois.Bogaert May 03 '19 at 08:38 AM

Hello Matthew,

First of all thank you for your answer and thanks for editing the report !

I understand the answer given, but it seems changing the plugin type to Editor doesn't affect the behavior. I tried it before posting but went ahead and double checked it : I set the only module contained in the plugin to "type:Editor". I created a new Blutility inheriting from our C++ class inheriting itself from UGlobalEditorUtilityBase and yet this newly created Blutility doesn't have access to desired functions.

I also tried to create a C++ class inheriting from UGlobalEditorUtilityBase straight into our project, outside of any plugin. A Blutility inheriting from this class doesn't have access to UGlobalEditorUtilityBase's functions (such as 'For Each Selected Actor').

As a side note, the documentation found in this page says the following about type:Developer :

Developer modules will only be loaded in development runtime or editor builds, but never in shipping builds

However, trying to create a Shipping Build of our game with the plugin's module set as "Developer" still tries to include the plugin in the build, resulting in the same above error. Which seems like another non-intended behavior, although I am more interested in seeing the first mentioned problem resolved.

avatar image Francois.Bogaert May 15 '19 at 03:52 PM

Hello,

Would you have any news about this topic ?

Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question