x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How to get dynamic shadows on translucent surface?

I'm trying to get dynamic shadows casted on translucent surface but can't find how. I've read that I should use "per pixel lighting", which means using the "Surface ForwardShading" as lighting mode in the translucency settings ( https://docs.unrealengine.com/en-us/Engine/Rendering/LightingAndShadows/LitTranslucency ) but it doesn"t work. Here are two screenshots with the material set to opaque, then to translucent with an opacity set to 1 for testing purpose (and "Surface ForwardShading" lighting mode) alt text alt text

Product Version: UE 4.22
Tags:
opaque.png (703.3 kB)
translucent.png (590.8 kB)
more ▼

asked May 03 '19 at 12:05 PM in Rendering

avatar image

Haoris
174 7 14 24

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Currently, only translucency volume(surface translucency volume) shadows work on deferred.

more ▼

answered May 03 '19 at 12:11 PM

avatar image

Deathrey
7.8k 130 31 292

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Setting the lighting mode to "surface translucency volume" which is the default lighting mode doesn't make the surface to receive a dynamic shadow. That's why I tryied with the "Surface ForwardShading" mode as it seams to be made for this if I read this correctly : https://docs.unrealengine.com/en-us/Engine/Rendering/LightingAndShadows/LitTranslucency Do you mean that something like water surface can't reveice shadows like this? : alt text

more ▼

answered May 03 '19 at 03:56 PM

avatar image

Haoris
174 7 14 24

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question