x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Anim notify don't replicate

Hi guys , so I'm spawning a weapon and attaching it to the players back , that part works fine . The problem is when I try to play an animation and a when the animation is close to done playing , I call an anim notify that detach the weapon and destroy it , and spawn the weapon and attach it to the player's hand , what happens whan I'm on the client is that the anim notify is called but the weapon is not destroyed and it still shows on the player's back but when I look at the server both the server and the player's weapons are destroyed .

But when I detach the weapon and destroy it not using an anim notify but by pressing a button it works fine . knowing this is how I play the animation ( the player presses a button it calls an event ( witch is replicated to run on server ) the event sets an anim montage to the animation I want to play , and then sets a boolean replicated(repNotify) to the revers of it is so the value always change and plays the animation on the boolean repNotify . And like I said the animation plays fine both on the client and on the server , the animNotify is the problem . So is the problem is with the way I play the animation ? , or with the way I use animNotify ? , or with both ?

And thank you

Product Version: UE 4.19
Tags:
more ▼

asked May 06 '19 at 06:47 PM in Blueprint Scripting

avatar image

Tomx990
3 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question