x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Global Shader Cache is missing. UE4.3

Hi there,

I'm having a problem with the cooked content. When we try to run the game with UNCOOKED content, we are using Debug Editor or Development Editor with the -game command option. That's run fine.

The problem raises when we try to run COOKED content in Debug or Development configuration. The game began to execute but the engine rises the pop up that says:

"The global shader cache file '{0}' is missing.\n\nYou're running a version of the application built to load COOKED content only, however no COOKED content was found. Consider cooking content for this build, or build and run the UNCOOKED version of the application instead."

This is because the files GlobalShaderCache-PCD3D_SM4.bin and GlobalShaderCache-PCD3D_SM5.bin it isn't being generated.

Obviously, we cook the desired maps with the unreal frontend tool before to run the game. I've been trying to apply many solutions that I've red in the forum and the answerhub, but the problem persists.

In the 4.1 engine version, the problem doesn't exists, it comes with the 4.3 version integration.

I've tried to set the default game server mode to other mode than none. Maybe, Is any root data folder wrong?

I will be posting any advance or clue that you may need. Thanks in advance.

Product Version: Not Selected
Tags:
more ▼

asked Aug 27 '14 at 09:41 AM in Using UE4

avatar image

Juanma.elx
39 3 5 14

avatar image Juanma.elx Aug 27 '14 at 09:55 AM

The cooked content process finish succesfully. But the .bin GlobalCacheShader files are not being generated.

avatar image Juanma.elx Aug 27 '14 at 10:39 AM

Other clue: the engine is looking for the GlobalShaderCache-PCD3D_SM5.bin and the GlobalShaderCache-PCD3D_SM4.bin in this folder:

UnrealEngine4.3/Engine, i.e., those files will be siblings of the Binares, Source, intermediate, etc, folders. That's weird and must be wrong.

I think that the problem is on any .ini file.

avatar image Juanma.elx Aug 27 '14 at 05:47 PM

UE4.3 Release Notes: " - Cooked sandbox paths have changed from Game\Saved\Sandboxes\Cooked-Platform to Game\Saved\Cooked\Platform."

Is there any known issue related with this change in the engine?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Switching to "DebugGame Editor" or "Development Editor" fixed this for me.

This forum thread (Lauren Ridge's comment) helped solved it: https://forums.unrealengine.com/showthread.php?1993-GlobalShaderCache-PC3D_SM5-bin-is-missing

more ▼

answered Sep 05 '14 at 01:45 PM

avatar image

smilingrob
570 19 31 49

avatar image ryandlf Oct 14 '16 at 03:18 AM

Me too. I kept thinking it was something with the engine but it was Visual Studios DebugGame (notice the missing Editor) that was giving me the problem. Switch over to DebugGameEditor and it works.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

If i understand correctly GlobalShaderCache-PCD3D_SM5.bin (and lots of other things) is generated by cooking, if the setting Platforms->Windows-> DirectX11(SM5) is ticked on. I had the same problem and the setting above was the solution.

more ▼

answered Jun 27 '15 at 12:46 PM

avatar image

mkadlec712
6 1

avatar image VictorRachels Oct 12 '16 at 04:51 AM

Checking the dx11 fixed the issue for me. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I suddenly started getting this error out of no where when running from VS with "DebugEditor" build config. I changed VS build config to "DevelopmentEditor" which worked. Then I switched it back to "DebugEditor" and the error went away.

more ▼

answered Aug 31 '17 at 07:25 AM

avatar image

sytelus
256 17 31 48

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question