x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Plugin class redirection from another module

Dear developers,

I have a custom c++ class (called CameraTop) which inherits from ACameraActor, located inside a plugin named VoRCharacterVisit. This plugin has 2 modules : VoRCharacterVisit (type Runtime, with the CameraTop class) and VoRCharacterConfigurator (type Editor ).

I've modified the CameraTop Class in order to add some editor features. Now i want to move the CameraTop Class from the VoRCharacterVisit module into VoRCharacterConfigurator module.

Issue : A Blueprint asset, named CameraTop, inherits from the CameraTop C++ class, and i can't succeed to do a classredirection, so my BP CameraTop has a invalid parent when i want to move my base c++ class CameraTop into the VoRCharacterConfigurator module.

What i tried :

I've added these lines in my DefaultEngine.ini :

 [CoreRedirects]
 +ClassRedirects=(OldName="CameraTop",NewName="/Script/VoRCharacterConfigurator.CameraTop")

As it doesn't seem to work, i tried with more "precise" info

 +ClassRedirects=(OldName="CameraTop", NewName="/Script/VoRCharacterConfigurator.CameraTop")
 +ClassRedirects=(OldName="/Script/VoRCharacterVisit.CameraTop", NewName="/Script/VoRCharacterConfigurator.CameraTop")
 +ClassRedirects=(OldName="VoRCharacterVisit.CameraTop", NewName="/Plugins/VoRCharacterConfigurator.CameraTop")

I tried to put these lines inside a new config file : /Game/Config/VoRCharacterVisit.ini

I've added the MODULE_API define in my class declaration

 UCLASS()
 class VORCHARACTERCONFIGURATOR_API ACameraTop : public ACameraActor

I'm able to open/edit the faulty Blueprint, even with the Warning of invalid parent, but once the edit window is open, i cannot reparent blueprint from the File menu : CameraTop isn't in the list. That said, i'm able to create a new blueprint with my VoRCharacterConfigurator.CameraTop as parent.

Cannot reparent camera

I had no issue doing activeclassredirect in version UE 4.18, but since i must use the [CoreRedirects] in 4.20. I cannot succeed to make this redirection.

  • Is there a issue with my naming ? Plugin and module names are similar

  • Is it possible to do a +classRedirect from one module to another in the same plugin ?

I'm working with a custom rocketBuild based on 4.20.3, and doing my testing with a DebugGame Editor built from VS 2017.

Any ideas or suggestions is welcome. Thanks in advance

Product Version: UE 4.20
Tags:
reparentcamera.jpg (152.7 kB)
more ▼

asked May 10 '19 at 01:12 PM in Using UE4

avatar image

Marcassin__
30 7 13 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question