x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Project Crashes while opening / MacOS Metal

I have a project that used to open fine on both MacOS and Windows 10 but most of the development has been on Windows.

Today, I tried to open it on MacOS and it now crashes the editor every time. Reaches over 90% then the loading window disappears and a second later the crash reporter pops up.

Here's some of the text from the log to help identify precisely where the error is happening in the loading process:

 Command Buffer Unknown Failed with InvalidResource Error! Error Domain: MTLCommandBufferErrorDomain Code: 9 Description Invalid Resource (IOAF code 9) Unknown Unknown
 
 LogMac: 0x0d398f2b UE4Editor-Core.dylib!FGenericPlatformMisc::RaiseException(unsigned int)   [UnknownFile]) 
 0x139757d3 UE4Editor-ApplicationCore.dylib!FMacErrorOutputDevice::Serialize(wchar_t const*, ELogVerbosity::Type, FName const&)   [UnknownFile]) 
 0x0d641fa0 UE4Editor-Core.dylib!FOutputDevice::LogfImpl(wchar_t const*, ...)   [UnknownFile]) 
 0x0d557c2e UE4Editor-Core.dylib!FDebug::AssertFailed(char const*, char const*, int, wchar_t const*, ...)   [UnknownFile]) 
 0x34484eb4 UE4Editor-MetalRHI.dylib!ReportMetalCommandBufferFailure(mtlpp::CommandBuffer const&, wchar_t const*, bool)   [UnknownFile]) 
 0x344d9191 UE4Editor-MetalRHI.dylib!MetalCommandBufferFailureInvalidResource(mtlpp::CommandBuffer const&)   [UnknownFile]) 
 0x34483623 UE4Editor-MetalRHI.dylib!HandleMetalCommandBufferError(mtlpp::CommandBuffer const&)   [UnknownFile]) 
 0x34483555 UE4Editor-MetalRHI.dylib!HandleAMDMetalCommandBufferError(mtlpp::CommandBuffer const&)   [UnknownFile]) 
 0x34483388 UE4Editor-MetalRHI.dylib!FMetalCommandList::HandleMetalCommandBufferFailure(mtlpp::CommandBuffer const&)   [UnknownFile])

Looking at the logs the crash is happening inside UE4Editor_MetalRHI so I believe this is related to compiling shaders with Metal. Since we can't open the project we can't try and remove or rework things to fix the issue. Any ideas how we might get past this problem and get it opening again?

An archive of the full crash report folder is included. And I included the log from the editor trying to start up. Any help would be much appreciated!

UPDATE - Workaround

I went through and systematically removed assets until it would open again (started with folders, then worked down until I found the specific .uasset file causing the issue). It turned out to be a texture asset used by one of our materials in the scene. This asset causes no issues on Win64 but crashes the editor in MacOS. If I try and add it back in after the project loads it is okay until I click on it or even hover over it. Any attempt to interact with the asset in the content browser produces the exact same crash already documented.

I was not responsible for this particular asset so I'm going to need to talk to the person that created it to try and figure out what is wrong. I will update here if I find any way to restore it to a working state on MacOS with Metal.

Seth B.

Editor Startup log

Crash Report Folder

Product Version: UE 4.20
Tags:
grove.log (32.4 kB)
more ▼

asked May 11 '19 at 10:10 PM in Everything Else

avatar image

berriers
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question