x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Texture turns dark in viewport and after Building Lights

Some of my textures turn dark in the viewport and after building the lights. But in the blueprint editor and material editor it appears to be normal. Please Help!

alt text

alt text

Product Version: Not Selected
Tags:
og.jpg (79.3 kB)
dark.jpg (109.7 kB)
more ▼

asked Aug 27 '14 at 12:17 PM in Rendering

avatar image

Hybreed
16 5 8 11

avatar image Lovecraft_K ♦♦ STAFF Aug 27 '14 at 03:23 PM

Hey Hybreed -

There are a few possibilities of what could cause this darkening. Since from your image it looks like texture is still rendering we can eliminate the Lightmap Channel as being at issue. Since it looks like you might be dealing with a darker material to begin with have you tired turning eye adaptation off by going into or adding a post process volume, make sure it is unbound and setting the Auto Exposure >> Min Brightness and Max Brightness to 1.

Also a screenshot of what the mesh looks like in the material editor or blueprint component view would be helpful for comparison.

Thank You

Eric Ketchum

avatar image Hybreed Aug 28 '14 at 06:58 AM

Hey Eric Thanks for your reply!

I tried your method by changing the Exposure setting >> Brightness 1 and adding a Post Process Volume and making it Unbound and still the textures are dark. And when I switch it to Mobile Preview it is completely UnLit, I added a Lightmass Importance Volume but nothing happened. I'm adding screenshots of the Blueprint Editor and Mobile Preview !!alt text alt text

blueprinteditor.jpg (180.8 kB)
mobpreview.jpg (302.5 kB)
avatar image Hybreed Sep 04 '14 at 04:37 PM

Hi Eric! We are trying to compile the map for a mobile device, we haven't turned on any sort of mobile settings it's just the default materials present in the blank map.. Is this the bug in the engine's update..?

avatar image mhanbildiren Apr 17 '19 at 10:30 PM

alt text what's this problem? I builded the all of things then they gets black, i changed coordinate of lightmap 0 to 1 but it becomes like this photo. How can i solve?

ekran1.png (918.8 kB)
avatar image fighter5347 Aug 28 '14 at 07:06 AM

Have you already added a "reflection capture actor" to your level?

avatar image Hybreed Aug 28 '14 at 07:25 AM

Yes I 've already added Reflection Capture, still the same result.

avatar image Lovecraft_K ♦♦ STAFF Aug 28 '14 at 05:27 PM

Hey Hybreed -

Could you post a screenshot of your UV layouts (UV0 and UV1)? Also, if you are willing you could upload the fbx of the actual mesh and we will look at for you?

Thank You

Eric Ketchum

avatar image Hybreed Aug 29 '14 at 07:53 AM

Hey Eric, I'm attaching the UV layout Screenshots and FBX files!

This is the Dropbox link for FBX Mesh, kindly have a look. https://www.dropbox.com/s/87v8ufei5lpkil9/FBX%20Mesh.rar?dl=0

Thank You! alt text

alt text

vent_uv0.jpg (345.8 kB)
vent_uv1.jpg (334.6 kB)
avatar image Lovecraft_K ♦♦ STAFF Aug 29 '14 at 02:02 PM

Hey Hybreed -

I received your FBX and have been testing with the engine.

Just wanted to check a simple solution, have you built lighting? Also is the influence of the Sphere Reflection Actor encompassing the meshes? What material have you applied to the mesh.

Thank You

Eric Ketchum

avatar image Hybreed Aug 29 '14 at 04:22 PM

Hey Eric,

Yes i've Built Lighting and the actor is in the radius of the Sphere Reflection Capture and i also tried the Post Process Volume with your settings but still the same result. And the texture on the mesh is stainless steal which i made. Is there some problem with the normals ?

Thank you

avatar image Lovecraft_K ♦♦ STAFF Aug 29 '14 at 05:13 PM

Hey Hybreed -

I have tested your mesh with our M_Steel and M_Chrome Starter Materials and it renders fine for me. Try those materials on your Project just to make sure that the render is fine, if so we need to look at your material setup, could you post a screenshot of that?

Thanks

Eric Ketchum

avatar image Hybreed Aug 30 '14 at 06:13 AM

Hey Eric, Thanks for the reply.

I tried the Materials from the starter content and the texture renders fine but somehow the colour of the texture changes for example the M_Metal_Burnished_Steel Material has a Bluish tint but it is not rendered i'm getting gray colour.

I'm attaching a screenshot of the Material which I made and the render of the Steel Material from the starter content please have a look.

alt text

alt text

m_metal_steel2.jpg (413.4 kB)
00.jpg (369.5 kB)
avatar image Hybreed Sep 01 '14 at 08:28 AM

Hey Eric,

I opened the Starter Project in Unreal Engine 4.4.1. The material on the default mesh present in the viewport works fine but when same mesh and the material is imported from the content browser to the viewport the materials turns dark. Is this a bug or some other issue which we cant figure it out! Please Help!

Thanks Hybreed.alt text

bug.jpg (436.0 kB)
avatar image Lovecraft_K ♦♦ STAFF Sep 02 '14 at 06:45 PM

Hey Hybreed -

I believe something is a miss with your normal map and it is this error which is causing your problems. Could you upload a copy of it to look at?

Thank You

Eric Ketchum

avatar image Hybreed Sep 03 '14 at 06:26 AM

Hey Eric,

The materials on both the chair are default M_steel from the starter content its just that the Chair with the darker material was dragged into viewport and the other chair was present in the viewport from beginning. I'm attaching a screenshot of the material editor.

Thanks!

alt text

avatar image Lovecraft_K ♦♦ STAFF Sep 03 '14 at 01:35 PM

Hey Hybreed -

Rebuild lighting in the above scene and does the imported chair look like the existing chair? The Reflections have not been added to the imported chair until you rebuild lighting which will update the Sphere Reflection Actor's cubemap and apply said map to the materials.

Thank You

Eric Ketchum

avatar image Hybreed Sep 04 '14 at 05:59 AM

Hey Eric,

I have rebuilt the Light and the the Sphere Reflection actor is updated as for the chair both the chairs are the same. The screenshot which I uploaded in the above comment has the light rebuilt in production quality! This happens everytime I open a new project!! I don't know what is causing the problem..Please HELP!

Thanks.

avatar image Lovecraft_K ♦♦ STAFF Sep 04 '14 at 02:57 PM

Hey Hybreed -

Are you using any mobile settings in the construction of the materials? All materials in Mobile have full roughness which means a limited amount of Screen Space Reflections and for metallic surfaces you will get more of a dark texture without the added cubemap from reflections.

Also what is your lighting setup is it just a directional light like in the default levels? Are the chairs static or movable?

Thank You

Eric Ketchum

avatar image Lovecraft_K ♦♦ STAFF Sep 04 '14 at 06:09 PM

Hey Hybreed -

I did some further testing and the black you are seeing is caused by the lighting not being rebuilt. I can only duplicate your results by placing a chair in the level and applying metal material without rebuilding lighting. In my mobile preview though I am seeing a warning message "Lighting needs to be rebuilt (1 unbuilt object(s))" Have you or anyone in your team disabled this warning? If you are still getting a black texture after building lighting, I am going to need to have a look at your whole project. I will need the *.uproject file, content and config sub-directories. If you can try to remove any non-necessary elements from the content browser to make a smaller file size.

Thank You

Eric Ketchum

alt text

alt text

chairs01.jpg (229.5 kB)
chairs02.jpg (211.5 kB)
avatar image Hybreed Sep 05 '14 at 06:43 AM

Hey Eric, Thanks for the reply... The solution you gave is working on the Starter Project but is not working on a blank project with no starter content. The Problem is half solved! I'm giving you the Dropbox Link for the Project...!!

https://www.dropbox.com/s/pnntw3xfxt7pqou/MyProjectTestBlank.rar?dl=0

Thanks!

alt text

alt text

blankmap.jpg (140.3 kB)
starterporj.jpg (125.2 kB)
avatar image mhanbildiren Apr 17 '19 at 10:30 PM

alt text what's this problem? I builded the all of things then they gets black, i changed coordinate of lightmap 0 to 1 but it becomes like this photo. How can i solve?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Hybreed -

There is some settings in the World Settings which are not set in the Blank no starter content version of a map. The biggest one which will help you is Environment Color, in the "No Starter Content" and change the color from Black to a light blue (which is how its set in the "With Starter Content").

more ▼

answered Sep 05 '14 at 01:43 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 256 733

avatar image Hybreed Sep 09 '14 at 05:50 AM

Hey Eric,

Your solution worked ... but had to create some parts of the project again! Thank you soo much for your Help !!!

Hybreed.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question