x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

texture's not displayed propely in- game/editor

hi, i'm really new to using ue4, so maby this is a stupid queston but I have a problem with some with my texture's..

for some reson it shows them propely in the materiaal edtior but not in-game (or in the level editor)... already played around with texture coordinates, but seems to do nothing at the moment.. does someone maybe have a vlue why it is doing this?

alt text

thx already for reading and thinking! ;)

Product Version: UE 4.22
Tags:
m-problem-1.jpg (204.5 kB)
more ▼

asked May 15 '19 at 01:25 AM in Rendering

avatar image

GRooVy GRoVer
10 3 1 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

You cannot do that in unreal. It has to be done in the program where you created the mesh. Or if you just downloaded the mesh from somewhere else you have to export it and open it in a 3d modelling software (3ds max, Blender, Cinema 4D or whatever) and make the UVs there. If you cannot do that maybe the last option is to use the "World aligned texture" node in your material. That would work to show the texture with some simple cube mapping but anyway you will never be able to bake the light without proper UVs on the mesh.

more ▼

answered May 15 '19 at 02:00 PM

avatar image

Caroo
133 1 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Cannot tell for sure but most likely you mesh has not proper UVs. They are either too small or they are missing.

more ▼

answered May 15 '19 at 06:55 AM

avatar image

Caroo
133 1 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

If slightly messed up texture mapping is OK for you you can use this trick: Auto generate lightmap UV's but in material change UV channel to the one you generated lightmap UV's on. you will see your texture mapped on object but it will be far from perfect. Other option you can use is to setup world space aligned material and use that as that way you do not need to have unwrapped mesh and you can use it without UV's.

more ▼

answered May 15 '19 at 08:11 PM

avatar image

Vertex Soup
288 4 22 16

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I think you right!

if tried to use a texture on the floor of the first persoon example map, and there it worked perfectly fine!

but now i don't know how to generate a uv map for my meshes.. i have read the documentation from epic, have watch multiple tutorials but i don't understand why its not working.

alt text

i tried to check the "generate lightmap uv" but it doe'tn seem work.. :( do you maybe know how I can fix that? :)

uv-problem-1.png (750.8 kB)
more ▼

answered May 15 '19 at 12:51 PM

avatar image

GRooVy GRoVer
10 3 1 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

oh of course! srry. how stupid of me.. xD now I've watchst a blender tutorial. i completly understands whats going on.. thx for helping me! ;D

and also good to know about the world space aligned material, then i have a backup for if i screw up ;p thx a lot! :)

more ▼

answered May 15 '19 at 09:20 PM

avatar image

GRooVy GRoVer
10 3 1 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question