x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error: Unknown Cook Failure. It's referencing a deleted plugin?

Hi, I'm trying to cook+package a build of my project but it's erroring out and failing, with the error" Error: Unknown Cook Failure". It seems to be trying to load a plugin that I once tried, but decided to disable and delete. I've deleted all files relating to it from the project, and I can't find any references pointing to it. I've tried deleting my Saved Config and Intermediate folder, but no luck. I see there's some warnings too about other files but I'm not sure why it's not finding them properly? It's saying for example it can't find '/Game/SC_SoundFX'. But it's actually in '/Game/Content/SoundStructuresAndTables/SC_SoundFX' So i'm not really sure why it's trying to fetch it from the root folder instead?

What could I do to be able to get my project to build successfully? Any help would be greatly appreciated, thank you! <3

Here is the full log: https://pastebin.com/QWD7hTH1 And just the error+warnings log: https://pastebin.com/VdZ5kV89


EDIT: I found how to fix it. Go in to your projects folder in explorer and find and remove any unused assets. I had deleted an actor that was using the plugin a while back, and it didn't show up in my project, but in explorer the file was actually still there!. So i deleted it manually, and now my project builds successfully.

Product Version: UE 4.22
Tags:
more ▼

asked May 16 '19 at 04:11 AM in Packaging & Deployment

avatar image

xcloudx01
1 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question