x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Fatal Error happened when I start my packaged project

alt text

Hi,everyone.I have been puzzled with a weired problem. I made a simple project demo and totally just use blueprints. i finished and then i build 、cook and package.Every step was successful. But when i start my game ,it showed an error like the picture below.i have no idea how to deal with it .Please help me !!

Product Version: UE 4.20
Tags:
more ▼

asked May 18 '19 at 01:31 PM in Packaging & Deployment

avatar image

Canligan
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Look here https://issues.unrealengine.com/issue/UE-48233

his occurs because there exists a circular reference between the nativized parent BP and the non-nativized child BP asset (which is a data-only Blueprint in this case). Current suggested workaround is to force the child BP to be nativized as well, by adding a dummy variable or component to the 'ChildBP' asset. A crash will still occur with EDL disabled as well, although the callstack/assert will be different.

I would suggest packaging with nativized unticked and see what happens.

more ▼

answered May 18 '19 at 02:00 PM

avatar image

Podgyhodgy
246 4 7 13

avatar image Canligan May 19 '19 at 02:34 AM

Thanks,i checked my project and i do have a parent BP and two child BP,but the parent BP have no any variable,i have no idea whether it will cause the error.By the way,i saw an official learning tutorial and the teacher say a concept which call blueprints dependency like BP A have a BP B object reference as a variable and BP B the same as A so that they have a cycle.And in my projcet,i have a playerBP and Animation BP and they have each object reference as variable. I don't know whether it will cause any problem?

avatar image Podgyhodgy May 19 '19 at 10:42 AM

I have never had this problem (yet) but here is my guess about why it might be a problem. If the player BP is created first then it cannot get a reference to the animation BP which has not been created yet. But you cannot create the animation BP first because it would need a reference to a player BP which has not been created yet. But it seems to me that this is only a problem if the references are created at the time of BP construction. If both BP are constructed then afterwards they should be able to get a reference to each other. I could be completely wrong. But that would be my working theory.

I suppose what I would do is arrange the code so that the reference variables are only populated when everything has been constructed - maybe in beginplay. I would be interested to see the actual BP setup that you have. I like these sort of problems. They are a bit painful but you end up learning something. I like the programming challenge - I am not really very interested in the actual game

avatar image Canligan May 19 '19 at 11:18 AM

i have debugged for a whole afternoon,i delete many assets and package it.There was only one situation that i delete my map and use the TPP template map can package successfully and play.At the begining, i thought that could be the problem of assets loading,but when i choose the default map and not use any assets,it can play.And that make me so crazy.i do not know what else can i do.And about the issue of blueprints dependency, i thought that it may not be the true problem because i delete my player in my level but it still can not to play. it proved it is not the reason of causing the problem

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question