x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Could not find a function named "None" in character BP only on initial launch.

Unreal Version 4.21.2

I am getting the error: Could not find function named "None" in Character_Pawn, make sure that Character_Pawn has been compiled for. This only happens when I first launch unreal. All I do to fix it is hit compile and then everything works fine. I tried saving all and re-launching but it keeps happening so I keep having to hit compile whenever I first open the project.

alt text

alt text

When I click on "None" it takes me to a collapsed graph with no errors in sight. I even tried disconnecting this graph completely and the error still comes back (the collapsed graph only contains one input and no output).

I have also tried migrating the Character_Pawn blueprint to a clean project and get the same error.

Product Version: UE 4.21
Tags:
capture1.jpg (31.0 kB)
capture2.jpg (57.6 kB)
more ▼

asked May 18 '19 at 10:51 PM in Bug Reports

avatar image

Davie Ti
1 1 1

avatar image Jeff A ♦♦ STAFF May 20 '19 at 12:24 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi have you tried to refresh the collapsed node? Right-click refresh. Maybe you renamed a pin and it hasn't updated.

more ▼

answered May 19 '19 at 06:19 AM

avatar image

lkav
1.4k 9 5 10

avatar image Davie Ti May 19 '19 at 03:00 PM

Yes I have tried this and also refreshing all nodes to no avail. I even unplugged the collapsed node completely and it still throws an error on launch. The strange thing is that inside the collapsed node there is no error on any of the nodes. The error reference opens the collapsed node in a new tab but does not point me to any node specifically. Also if I expand the collapsed node and then compile unreal crashes completely. I'm installing debugging symbols now so I can see what the crash log says.

avatar image Davie Ti May 20 '19 at 01:33 PM

Here is part of the log:

Assertion failed: Result [File:D:\Build\++UE4\Sync\Engine\Source\Editor\UnrealEd\Private\Kismet2\BlueprintEditorUtils.cpp] [Line: 2274]

 UE4Editor_Core!FDebug::AssertFailed() [d:\build\++ue4\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:417]
 UE4Editor_UnrealEd!FBlueprintEditorUtils::FindBlueprintForGraphChecked() [d:\build\++ue4\sync\engine\source\editor\unrealed\private\kismet2\blueprinteditorutils.cpp:2275]
 UE4Editor_BlueprintGraph!UK2Node_CallFunction::HasExternalDependencies() [d:\build\++ue4\sync\engine\source\editor\blueprintgraph\private\k2node_callfunction.cpp:2603]
 UE4Editor_UnrealEd!FBlueprintEditorUtils::GatherDependencies() [d:\build\++ue4\sync\engine\source\editor\unrealed\private\kismet2\blueprinteditorutils.cpp:3022]
 UE4Editor_UnrealEd!FBlueprintEditorUtils::GetDependentBlueprints() [d:\build\++ue4\sync\engine\source\editor\unrealed\private\kismet2\blueprinteditorutils.cpp:3064]
 UE4Editor_Kismet!FBlueprintCompilationManagerImpl::FlushCompilationQueueImpl() [d:\build\++ue4\sync\engine\source\editor\kismet\private\blueprintcompilationmanager.cpp:425]
 UE4Editor_Kismet!FBlueprintCompilationManagerImpl::CompileSynchronouslyImpl() [d:\build\++ue4\sync\engine\source\editor\kismet\private\blueprintcompilationmanager.cpp:203]
 UE4Editor_UnrealEd!FKismetEditorUtilities::CompileBlueprint() [d:\build\++ue4\sync\engine\source\editor\unrealed\private\kismet2\kismet2.cpp:766]
 UE4Editor_Kismet!FBlueprintEditor::Compile() [d:\build\++ue4\sync\engine\source\editor\kismet\private\blueprinteditor.cpp:3258]
 
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question