x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Weirdest lighting bug out of nowhere...

I'm sorry for vague headline, but I have no idea how to describe what has happened in just couple words.

So I ran light building on my scene after placing some new assets, and then I came back to this:

www.youtube.com/watch?v=3cvsIigxv8g

I never seen anything like this happening before, and I've built lighting on this scene a lot of times prior to this bug.

Why could this be happening all of a sudden?

Product Version: UE 4.20
Tags:
more ▼

asked May 18 '19 at 10:21 PM in Rendering

avatar image

Kligan
51 11 15 22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

OK! I went back and thought about every change I've made before building the lighting, and here's what I found out.

I set the shaft of the torch to not use lighting channel 0 and use lighting channel 1 instead (to avoid weird lighting from the stationary point light on top of the torch). And then I enabled lighting channel 1 on the stationary point light at the lantern, so it could still affect the torch's shaft. And for some reason that bugged out spotlights that had light function to simulate water ripple reflections. After I enabled light channel 1 on those spot lights as well, the bug went away.

more ▼

answered May 18 '19 at 10:37 PM

avatar image

Kligan
51 11 15 22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question