x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

how do i disable static shadows for foliage, and only use dynamic shadows(procedural foliage volume)

Hi, well im using the procedural foliage volume, and when i set the directional light in stationary or static the foliage cast shadows, but i have a lot of trees, so i get errors. I try to uncheck "cast static shadow" in the foliage tool and in the foliage type asset , but it continue casting the shadows. I could set the directional light in dynamic, but i want to have the global illumination.

Someone knows how to only use dynamic shadows with the procedural foliage volume?

Thanks.

Product Version: UE 4.21
Tags:
more ▼

asked May 22 '19 at 02:03 AM in Rendering

avatar image

lfhguenin
1 1 1

avatar image ClockworkOcean May 24 '19 at 07:44 AM

What errors?

If you want dynamic shadows with the procedural foliage, you have to use a dynamic light.

avatar image lfhguenin May 24 '19 at 08:57 PM

the total lightmap size for this instancedstaticmeshcomponent is large without static shadow and instanced meshes don't yet support unique static lighting for each lod.

yes i know that i need dynamic light, so I use stationary, but continue casting shadows although i uncheck cast static shadows

avatar image Raidfire.Net May 24 '19 at 09:42 PM

Make your Light Sources moveable. Moveable Light Sources only generates dynamic shadows. Static or Stationary Light Sources generates Shadows Maps, if manually generated.

Regarding your issues. You have unchecked the "cast static shadow" and it still shows shadows, right? Maybe you have one moveable light source in your scene. If this is the case, it shows shadows all the time, cause these shadows are dynamic and not static, so it has no effect when toggling the "cast static shadows" checkbox.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question