x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

i have public variables, but they arent aviable to set up on other blueprints

i have public variables, but they arent aviable to set up on other blueprints even they are casting correctly and compiled but thats happen with all blueprints and all variables from other blueprints

alt text

Product Version: UE 4.20
Tags:
log.png (209.9 kB)
log-in.png (163.5 kB)
s.png (188.3 kB)
more ▼

asked May 22 '19 at 03:03 PM in Blueprint Scripting

avatar image

DiMpUlTiOnZ
1 1

avatar image the_batch May 22 '19 at 03:19 PM

It looks like your Blueprints are compiling okay. I don't see the problem in the screenshots you posted. Can you explain the problem a bit further?

avatar image DiMpUlTiOnZ May 22 '19 at 03:36 PM

the blueprint when i cast other blueprint, all public variables from that aren't available to set up or read as you can see on log.png

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

alt text

capture.png (239.7 kB)
more ▼

answered May 22 '19 at 03:54 PM

avatar image

DiMpUlTiOnZ
1 1

avatar image the_batch May 22 '19 at 04:21 PM

If you are trying to change the default value of a variable, that can only be done from within the blueprint class that 'owns' that variable.

Specifically, you can't change the default value for that OFFLINE variable from where you show it being highlighted. If you need to change that variable's default value, you'll have to do that in your "Login" class.

Everywhere outside of your "Login" class, you'll need to use a Set node to change that variable's value.

Hope that makes sense.

avatar image DiMpUlTiOnZ May 22 '19 at 04:26 PM

on this image im trying to read the variable to branch node but even the event on "login" blueprint i set checked it still false

avatar image the_batch May 22 '19 at 04:37 PM

Maybe things are being executed in a different order than you're expecting. I suggest trying to troubleshoot using debug print nodes or using the blueprint debug system to figure out what's going on.

avatar image Ronnie Olive May 22 '19 at 09:40 PM

If it's returning false, then it isn't being set to "True".

You'll have to show where it's being set to True, and confirming that the change is taking place. You can print the value after setting it to verify.

avatar image TiagoMaia May 23 '19 at 10:49 AM

What you can do is a print string where you are changing the value of a variable and then another print string where you want to check the value of the variable and see what comes first, if you don't know the order of your events that should help ( if one of the print strings is not showing it's because you are not calling something correctly )

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question