x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lightmass rendering black on some faces

I have been getting a strange bug where certain faces usually facing in one direction in both positive and negative render completely back. all of a sudden it started happening on meshes I haven't touched or changed anything on. I have tried what seems like everything, I have re uv'd, changed lightmap res, and countless other things. in one section i have had luck with just simply exporting and re importing while changing nothing and it has fixed the issue. In other areas that fix dosent seem to work. Ill post some images in lit, unlit, and lighitng only.

i tried migrating the level to a fresh project and it fixed some but introduced others. I also tried using cpu lightmass and im getting similar unpredictable errors. I am at a loss, I dont understand why all of a sudden these meshes started acting like this and I just cant figure out a fix or why its happening. alt text

alt text

alt text

alt text

Product Version: UE 4.20
Tags:
more ▼

asked May 22 '19 at 06:41 PM in Rendering

avatar image

dustintinkler
6 1 2 6

avatar image ClockworkOcean May 24 '19 at 07:36 AM

Might be a silly question, but do you have reflection captures in there?...

avatar image rfellers May 31 '19 at 01:36 PM

I am seeing the same issue - 4.22.1 (Oculus Branch). It is very odd. I've tried breaking the model apart in different ways then reimporting, different UV layouts, etc., but nothing seems to consistently work.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Maybe you are not using the correct UV map index and the probelmatic meshes have more than one? There is a setting. If you open the mesh in the static mesh editor, "use light map index" or something similar.

more ▼

answered May 24 '19 at 11:29 AM

avatar image

BreakMaker
232 4 11 16

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question