x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Projectile goes through walls no matter what!

So I am trying to make projectiles not going through wall, I did everything I read online, used CCD, activate collision, yet... Nothing seems to work, hit event too doesnt work, physics material on wall doesn't work... I am trying to have a collision to 2 projectile a bullet, and a brick (thrown by a boss) and they both get through walls and so on.. I also put the collision box as root, but nothing works, if anyone could help me, that would be appreciated =/ also I am new in UE4

Product Version: UE 4.22
Tags:
more ▼

asked May 23 '19 at 03:30 PM in Using UE4

avatar image

VioletVTK
5 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I might need more information, but it Sounds like the collision channels aren't setup correctly. https://www.unrealengine.com/en-US/blog/collision-filtering Both objects need to be set to block each others channels: https://cdn2.unrealengine.com/blog/FilterTable-900x490-756106034.jpg

alt text So collision lets say your projectile is on channel "PhysicsBody" and your walls are on "WorldStatic". Then your projectile static mesh collision channel setup should block the "WorldStatic" channel and the Wall static mesh should block on the "PhysicsBody" channel.

Collision geometry can be setup in the Static Mesh Asset editor. You don't need to add that in blueprint (this would be useful for invisible collision checks)

If you open your static mesh asset, there should be a Symbol at the top row with the name "collision". This should mark the colsion as agreen wireframe. If unreal didn't setup a collision by itself you can add one in the very top menu point Collision. https://docs.unrealengine.com/en-us/Engine/Physics/Collision/HowTo/AddSimpleCollision Performance wise it usually cost more in that order: Sphere, Capsule, Box, Convex.

Btw. CCD is usefull for very fast physical collisions, compared to its size. It basically updates the position more often than usual and has a higher chance of intersecting with other collision. If you hover over the checkbox in the engine you'll get a tooltip for that.

more ▼

answered May 23 '19 at 04:06 PM

avatar image

BOBtheROSS
235 9 13 23

avatar image VioletVTK May 23 '19 at 04:30 PM

Thanks for all these info but anyway I figured it out, it was my fault I set up a projectile collision but yet still was going through wall, as it turns out, I forgot to add the "projectile" collision preset on my collision sphere for my projectile, my bad lol I only added it on my static mesh, so wasn't working, thanks either way

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question