x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

v4.4 crash in UEditorEngine::TeardownPlaySession

In PlayLevel.cpp:336

SlatePlayInEditorSession is dereferenced even if is NULL. As the previous if statement does check if the value is NULL, I'd expect this if statement to as well.

I'd made some other modifications to fix another issue which resulted in SlatePlayInEditorSession being null, and hit this crash....

Product Version: Not Selected
Tags:
more ▼

asked Aug 27 '14 at 11:37 PM in Bug Reports

avatar image

Roxie
41 1 2 3

avatar image Tim C ♦♦ STAFF Aug 28 '14 at 08:01 PM

Hi Roxie,

We will look into this issue for you. Would you be able to let us know what modifications you had made previously?

avatar image Roxie Aug 28 '14 at 09:12 PM

I made a modification to address https://answers.unrealengine.com/questions/89909/v44-pie-network-login-odd-interactions-with-the-on.html

To do that, I modified UGameInstance::InitPIE to take an additional WorldContextHandle (defaulting to none). If a valid handle is passed in, then I lookup that world context, instead of creating a new one.

Additionally, I made a modification to address https://answers.unrealengine.com/questions/89896/in-pie-standalone-why-doesnt-the-editor-log-into-t.html

I modified PlayLevel.cpp:1889 to run the OnlineSubsystem login regardless of the PlayNetMode.

These changes may or may not have anything to do with this issue...I'm still investigating.

avatar image Roxie Aug 29 '14 at 04:58 PM

FYI, I fixed some of this stuff as noted in https://answers.unrealengine.com/questions/89883/v44-crash-during-networked-play-in-editor.html

My thoughts on the cause are there as well.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Roxie,

Thanks for pointing this out. This issue has actually been fixed in our main branch, and is accessible in the latest code available on GitHub. Of course the fix will also be included in the 4.5 release!

more ▼

answered Aug 29 '14 at 05:04 PM

avatar image

Ryan Gerleve STAFF
1.1k 25 12 49

avatar image Roxie Aug 29 '14 at 05:25 PM

You guys rock. I'll use 4.5 when it comes out.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question