x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How can I make the editor show shaders again?

So I've been learning how to develop a game using unreal engine and lets just say it's slow. I haven't run into any major problems with the engine since I started using 4.0. I've been following the updates and every one until 4.4 have been great. Now I have run into the problem in the editor which occurred when I was running 2 editors at the same time. (Not a problem before 4.4) There was a message that popped up on my screen while closing one of them that said something about engine was running under 10fps for 30 seconds and was going to optimize I think. Now I don't get the sun in game and the camera unrenders a small field of clouds when looking directly at them. I can see everything else like 3d models but I can't see how the game looks when running. When I click play and the game runs everything fine. I don't know where to go to solve this problem. It also seems to be only my project because I tried another project from epic and that loaded fine. How can I make the engine display the shadders again?

In editor: alt text

In game: alt text

Product Version: Not Selected
Tags:
editor.png (139.9 kB)
in game.png (183.2 kB)
more ▼

asked Aug 28 '14 at 04:05 AM in Using UE4

avatar image

GamerAtHeart
1 1 1

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

In that first screenshot there's a button at the top of your screen that says "Show". If you open it up it should have a check box for hiding / showing a bunch of elements like particles etc. That might be your fix

more ▼

answered Aug 28 '14 at 07:15 AM

avatar image

greynz
237 25 15 26

avatar image GamerAtHeart Aug 28 '14 at 02:46 PM

Thank you for your reply! Just so you know I've been working with the editor for several months so I know most of the options available to me in the editor. I decided to give the "show" menu another look and nothing is different. Not really the menu I'd need to use for this anyway. I did narrow the problem down even further. It's only to do with the specific level that I have open and the blueprint I made for the sun a month ago. I tried adding my sun blueprint to another level and no sky or sun appeared in editor and in game. The original atmospheric fog component I left in game but made invisible and forgot about works. When I make it visible just now it shows up in editor. I also tried replacing my sky blueprint with a backup and that didn't work either. Still a little stumped on the problem. Never had this problem before 4.4.1.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question