x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged project crashing on startup 4.22 after adding a c++ class to project.

Hello!

I have been having an unusual issue where my packaged game is crashing immediately upon startup with a fatal error message, but it will restart and run normally from that point onwards, even on repeat plays.

Bug Screenshot

The logs aren't showing anything that seems obvious, and the project did not have any errors or warnings whilst packaging. I've looked online at all other possible solutions and I can't find anything, I have tried this on a new project and I don't get the issue, but I have tried a new map in the existing project with a standard third person pawn and I still get the crash. I don't really know what else it could be inside my project. :S

Any possible suggestions with what this could be would be super helpful, I'm running out of options.

Packaged game log

Product Version: UE 4.22
Tags:
more ▼

asked Jun 05 '19 at 09:39 PM in Packaging & Deployment

avatar image

JBroderick
189 8 9 24

avatar image JBroderick Jun 07 '19 at 02:48 PM

I've managed to narrow the problem down to a specific area. It turns out that I get this whenever I add a C++ class to a project. I have managed to replicate this issue on a blank project in 4.22. I was specifically adding a Blueprint Function Library class.

Anybody know what this could be?

avatar image Cipher5 Jun 11 '19 at 10:30 AM

I have same problem

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question