x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Swarm Network Distribution

Hi,

in the last days I tried to get Swarm working properly. I want to use 3 computers for the lighting calculation. The Swarm coordinator find all agents. But as other users have the same problem the connection drops randomly for no reason. I tried a lot of things and read nearly every post I could find on this topic.

  • Firewall is setup to allow ICMP and incoming / outgoing remote ports

  • The game folder is shared in network

  • The groups and names are setup

  • All PCs are available

I use a gigabit network with cable network router. All PCs have Windows 10 installed.

Here are some images from my Swarm setup.

Hopefully someone has an idea how to solve it because I really need some hardware support for light build (even my current hardware is not the strongest).

Thank you!

Kind regards

Andre Schaaf-Ledermüller

Main Agent Swarm Coordinator Log File Configuration

Product Version: UE 4.22
Tags:
unbenannt.png (88.4 kB)
unbenannt-1.png (21.5 kB)
unbenannt-2.png (106.2 kB)
unbenannt-3.png (84.2 kB)
more ▼

asked Jun 08 '19 at 11:13 AM in Rendering

avatar image

andreschaaf
248 10 8 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

I could solve my problem by changing the SwarmAgent through code and runtime setup.

I changed the SwarmAgent source code and set the busy threshold value to 80%. Now the jobs are getting assigned and I also set within the Swarm settings the remote agent timeout to something very high: 10000. It seems that at some point it tries to ping the host agent. But when the agent is busy it will fail to answer the ping which leads then to a disconnect. With the high ping timeout this could be solved in my case.

Thanks.

more ▼

answered Jun 09 '19 at 07:53 AM

avatar image

andreschaaf
248 10 8 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question