x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blendspace WalkBack issue

You can easily notice this rather odd behavior if you just grab the animation starter pack off the marketplace, open up one of the associated blend spaces like Idle-Sprint and shift click the top speed around direction 140 or so.

Here is a short representation for the lazy or too busy folks: https://gyazo.com/fb8a3d79badea0ac54f45db1bf61be37

This is "default" behavior, nothing was changed it's just how the blend space interpolates between the back walk and the front walk for 4.22. it is the first time I actually notice the issue, so I wonder if this was always present or if it got introduced as one of the new features (ei: it's a bug).

Either way: What is the AAA method to fix this? Separate animation states for every direction like it already has to happen to eliminate twitching in the backwards walk movement?

Product Version: UE 4.22
Tags:
more ▼

asked Jun 10 '19 at 04:22 AM in Bug Reports

avatar image

MostHost LA
16 2 3

avatar image MostHost LA Jun 10 '19 at 04:48 AM

doing this works for removing the bug, I just can't believe I have to go re-partition over 20 animation states because of this -_-

https://gyazo.com/acb0ac958e4eb0abe567073af4b738cb

avatar image MostHost LA Jun 10 '19 at 08:24 PM

I looked into Sync markers. those aren't helping either.

The issue is still present in any 2d or 3d blend-space that uses interpolation speeds - the feet fight each other between idle and not idle - even with sync targets and the custom Speed Warp node.

avatar image MostHost LA Jun 12 '19 at 05:52 AM

I finally found a viable solution to this - I suppose one can categorize it as a "git good" answer because it really doesn't tackle the problem, it just completely circumvents it in the process of doing something entirely different.

The feet in my case are now being kept onto the floor via a custom IK system. This effectively prevents the bad behaviour from the blendspace to occur.

If you happen to stumble on this topic later on because you have a similar issue, the steps to correct it are as follows.

1) come up with an IK system that actually puts your feet on the floor correctly- took me around a week and I'm still not done but it's possible or you can purchase one.

2) convert the IK system Foot Translation nodes to use Animation Curves.

3) loose your mind creating the needed animation curves to get your feet to play nicely.

On the plus side, once this is implemented it completely solves any and all glitches because of the easing of the curve being completely customized to the animation - which, vs the notify I was utilizing prior - is a really nice upgrade.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question