x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Some Textures Are Bright Even Without Lights

Screenshot for reference: alt text

There are no lights at all in this scene or even a skysphere and the lighting has been baked under these conditions, yet clearly some specific materials look like they still have lighting while others look appropriately dark. These materials do not change or become dark when I hit "play" or "simulate".

These materials look just as bright even if they are applied to different objects.

Note: Everything in this scene is using meshes and materials that can be found in the default content folder and should be easily repeatable for those that are curious.

This project is the default, blank scene with no additional blueprints with all lights and volumes deleted.

The ultimate question: Why are these materials receiving light and how do I prevent this?

Product Version: UE 4.22
Tags:
problem.jpg (148.4 kB)
more ▼

asked Jun 18 '19 at 07:53 PM in Using UE4

avatar image

nomjomski
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I HAVE FOUND THE PROBLEM

I can not imagine how annoying this might become for someone that has no clue where to specifically find the controls for these things.

It all has to do with the "Environment Color" variable under the World Settings. By default it is set to a color that is not black and an intensity of 1. In order to solve this issue, and to ensure your lighting information comes only from your placed lights in your scene, either change the "Environment Color" to black, or turn the "Environment Intensity" variable to 0 in you World Settings.

If you have 4.22.1 or above and are struggling with this issue, I hope this finds you well. alt text

problem2.jpg (130.2 kB)
more ▼

answered Jun 20 '19 at 06:35 PM

avatar image

nomjomski
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi!

Maybe your normals are flipped?

more ▼

answered Jun 20 '19 at 02:22 PM

avatar image

Makigirl
1.3k 4 4 8

avatar image nomjomski Jun 20 '19 at 06:01 PM

Hello Makigirl, it is highly doubtful that the problem stems from flipped normal's because I am using geometry that is found in the starter content of the unreal project which should all have correct configurations and settings. Unless this is a known issue with starter content geo, I do not think flipped normal's would be the cause of this anomaly.

Also bear in mind that this issue should be easy to reproduce if you start a new, blank project in 4.22 and delete all the lights in it and add some default geo with the starter content materials applied to them (specifically any texture that is not very reflective).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question